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FIRMWARE VERSION 1.0.13.14 

 

PRODUCT NAME 

UCM6510 

DATE 

02/17/2017 

IMPORTANT UPGRADING NOTE 

¶ Firmware package downloading link is available in below firmware page: 

http://www.grandstream.com/support/firmware/ucm6510-official-firmware 

¶ Backup your data including configuration before firmware upgrade is recommended. 

¶ For UCM6510 on 1.0.12.19, please upgrade to 1.0.13.14 directly. 

¶ For UCM6510 on 1.0.11.27, please upgrade to 1.0.12.19 first, then upgrade to 1.0.13.14. 

¶ For UCM6510 on 1.0.10.44, please upgrade to 1.0.11.27 first, then upgrade to 1.0.12.19, and 

then 1.0.13.14. 

¶ For UCM6510 that’s still on 1.0.2.7 (or lower), please follow upgrading instructions to upgrade 

to 1.0.13.14: 

 

- Backup, Backup, Backup, yes, backup your data (including configuration) before doing 

any firmware upgrade! An SD card or USB Flash Drive is needed for backup purpose.) 

- For UCM6510, upgrading from firmware version 1.0.2.7 (or lower) to firmware version 

1.0.13.14 directly is not supported. The firmware upgrading process should be 1.0.2.7 (or 

lower) -> 1.0.2.97-> 1.0.10.44 -> 1.0.11.27 -> 1.0.12.19->1.0.13.14. 

- The UCM6510 will be reset to factory default settings after upgrading to 1.0.11.27.  Users 

need restore backup file manually or re-configure after upgrade. Therefore, it is VERY 

IMPORTANT to manually BACKUP data on the UCM6510 before upgrade. Users will also be 

requested for backup when upgrading from 1.0.2.97 to 1.0.10.44. 

- Once upgraded to 1.0.13.14, downgrading to 1.0.2.7 (or lower) is not supported. 

UPGRADING INSTRUCTIONS 

The following are the upgrade steps from 1.0.2.7 to 1.0.13.14. 

 

1. Upgrade UCM6510 from firmware 1.0.2.7 to 1.0.2.97 using the 1.0.2.97 “ucm6500fw.bin” file. 

2. When the UCM6510 is on firmware 1.0.2.97, open a web browser on a PC connected to the same 

network as UCM6510 to log in UCM6510 web UI. Go to Maintenance->Upgrade page, manually 

http://www.grandstream.com/support/firmware/ucm6510-official-firmware
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upload “ucm6500dpt.bin” file under Local Upgrade section from your PC. The “ucm6500dpt.bin” file 

can be found in the “Release_UCM6510_1.0.10.44.zip” folder in the firmware package. 

3. Once the UCM6510 finishes loading the ucm6500dpt.bin file successfully, it will reboot and 

automatically boot into recovery mode. 

4. In recovery mode, the UCM6510 LCD will display its IP address. Please type this IP address in the 

web browser of your PC that is connected to the same network as the UCM6510. Please make sure 

you have cleared your browser cache and type in IP address only (Do not specify protocol or port 

number). For example, if the IP address displayed in LCD is 192.168.1.2, please type in 192.168.1.2 

in the browser address bar. 

5. The following figure shows the UCM6510 web UI in recovery mode. Log in the UCM6510 as 

administrator. 

 

 

6. Once logged in (as shown in figure below), click on “Upload” and select firmware 1.0.10.44 

“ucm6500fw.bin” file from your PC to upload. 

 
 

7. Please keep the web page open and wait until uploading is finished. Once done, an upgrading 

successful message will be prompted. 
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8. On the recovery mode web UI, select “Reboot” to reboot the UCM6510. 

9. Your UCM6510 is successfully upgraded to 1.0.10.44. 

10. Please navigate to UCM6510 web UI, go to Maintenance->Upgrade page, manually upload firmware 

1.0.11.27 “ucm6500fw.bin” file to upgrade to 1.0.11.27. 

11. Once the UCM6510 finishes upgrading and boots up, upgrade the UCM6510 to 1.0.12.19 and then 

upgrade to 1.0.13.14. 

 

CHANGES SINCE FIRMWARE VERSION 1.0.12.19 

ENHANCEMENT 

¶ Added extension whitelist/blacklist for IVR dialing [BLACKLIST/WHITELIST IN IVR] 

¶ Added ability to include DOD in PPI Header for SIP trunk [DOD IN PPI HEADER] 

¶ Added ability to customize PAI Header [PAI HEADER CUSTOMIZATION] 

¶ Added blacklist for outbound calls [BLACKLIST FOR OUTBOUND CALLS] 

¶ Added support to upload/download MOH package from web UI [MOH UPLOAD/DOWNLOAD 

SUPPORT] 

¶ Added support to download custom prompts from web UI [CUSTOM PROMPT DOWNLOAD 

SUPPORT] 

¶ Added option to configure prompt timeout in Dial By Name [PROMPT WAIT TIME FOR DIAL BY 

NAME] 

¶ Improved seamless transfer privilege control. [SEAMLESS TRANSFER PRIVILEGE CONTROL] 

¶ Added RTP Keep-alive support. [RTP KEEP-ALIVE] 

¶ Added Email Send Log. [EMAIL SEND LOG] 

¶ Added PMS feature for hMobile Connect MSG interface so MWI will be sent to the phone when 

receiving the action MSG of the account. Currently all hMobile Connect interfaces are supported, 

including Checkin/Checkout/Status/Wakeup/Minibar/Move/Update, etc. 

¶ Added support for Mitel simulation/protocol interfaces for PMS module. 

¶ Removed restriction that only allows creating 3 failover trunks. Up to 10 failover trunks can be added. 

¶ Upgraded LIGHTTPD Web Server to latest version to address vulnerabilities. 

¶ Added description field in ZeroConfig settings to configure Softkey/Line/MPK for GXP series phones. 
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¶ Added support for PAI header pass-through. This is used in some special cases that the request 

from caller includes the PAI header to identify the source, e.g., a call from GXW41xx which 

contains the original number from PSTN line. 

¶ Added support for SIP Diversion header when the call it’s forwarded. This is used to identify the 

forwarded call and the original forwarder. 

¶ Added advanced IPv6 support including IPv6-to-IPv4 SIP calls, IPv6 router, IPv6 iptables/Static 

defense and etc. 

¶ Updated dropbear to v2016.74 

 

BUG FIX 

¶ Fixed Compatibility issue when upgrading CDR database 

¶ Fixed Conference: Conference information displays abnormal unless UCM is rebooted 

¶ Fixed Conference: Conference recording file is created abnormally when the admin presses */8/4 

multiple times after making MCB 

¶ Fixed Conference: UCM cannot subscribe CEI for MCB via IPv6 peer trunk 

¶ Fixed Conference: CCM function is unavailable after using it to invite members with special 

characters 

¶ Fixed Conference: UCM should play 'conf-now-muted (or umuted) .gsm' after admin user performs 

Mute/Unmute All by CCM 

¶ Fixed Conference: UCM sends wrong NOTIFY for refresh SUBSCRIBE in CEI 

¶ Fixed Conference: The caller name in conference is shown incompletely if the user name is too long 

¶ Fixed Conference: The talking status of the member is incorrect when the conference is on hold 

¶ Fixed Conference Schedule: Call transfer setting on extensions should not take effect for conference 

schedule 

¶ Fixed Conference: UCM should not send BYE to the user who is invited by CMM when “Send 

Remote Party ID” is enabled 

¶ Fixed Conference Schedule: The transfer target set on local extension should not take effect for 

invitation 

¶ Fixed Conference Schedule: Special Extension’s First Name displays incompletely when it receives 

the Email 

¶ Fixed Operation Log: Recording new custom prompt should generate operation log 

¶ Fixed Operation Log: The content for batch adding binding Mac address is incorrect 

¶ Fixed Operation Log: Batch modify extension has no operation log 

¶ Fixed Operation Log: There is no operation log when updating Feature Misc 

¶ Fixed Operation Log: There is no operation log about modifying “Allowed to Cal-Barge” setting 

¶ Fixed Operation Log: The outgoing call permission and seamless transfer permission operation log 

are the same 

¶ Fixed PMS: Extension that’s not bind to PMS shouldn’t be able to update PMS room status using the 

feature code 

¶ Fixed PMS: Wakeup service can be set with single service without date 
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¶ Fixed PMS: The credit value can’t be set to no data 

¶ Fixed PMS: It should play Consumer Goods failure prompt when the extension is not bind to PMS 

room 

¶ Fixed PMS: WebUI still displays Firstname or lastname after PMS client updates it to empty value 

¶ Fixed PMS: UCM will hang up the call when the consumer goods prompt is deleted 

¶ Fixed PMS: UCM should respond error when sending wakeup action with wrong time from PMS client 

¶ Fixed PMS: UCM can’t send all the wake status to PMS when the wakeup calls ring many rooms at 

once 

¶ Fixed PMS: Status is changed to checkout after maid status change 

¶ Fixed Extension: Some extension accounts can’t be deleted by deleting zeroconfig Auto Assign 

Extension 

¶ Fixed Extension: Web UI can’t save setting if DND Whitelist contains “-” 

¶ Fixed Call Queue: There is no prompt after time out in call queue 

¶ Fixed Call Queue: In some cases, 302 message will cause the call become abnormal 

¶ Fixed Call Queue: Call is routed into no answer destination before timeout 

¶ Fixed Feature Code: There is no chance to retry after password seamless transfer input timeout 

¶ Fixed Feature Code: The passive seamless transfer input timeout is too short 

¶ Fixed Feature Code: Parking timeout is invalid when dialing parking number via DISA 

¶ Fixed Feature Code: The voice prompt of inbound mode can’t support multiple language 

¶ Fixed Active Call: The callee displays “unknown” when making a minibar call 

¶ Fixed Active Call: UCM displays incorrectly when using active seamless transfer to transfer to 

external number via analog trunk 

¶ Fixed Basic Call: If CallerID Number is set with letters, using Seamless Transfer will behave abnormal 

¶ Fixed Basic Call: UCM should not send Email to wrong address in for voicemail to Email 

¶ Fixed Basic Call: UCM failed to hang up the call when receiving BYE before 200OK response 

¶ Fixed Backup/Restore: Extension that has MOH and language using customized values can’t restore 

to normal values 

¶ Fixed Backup/Restore: Voicemail count is incorrect after backup 

¶ Fixed Wakeup Service: UCM failed to set the year before the prompt is over 

¶ Fixed Wakeup Service: UCM doesn’t verify if the day is correct or not 

¶ Fixed Wakeup Service: The wakeup prompt is inaccurate if extension enables “Auto Record” 

¶ Fixed Email Settings: The Fax Email displays abnormal when Email Template Sending Format is plain 

text 

¶ Fixed Email Settings: UCM will not send strings that are after a space in the Display name parameter 

¶ Fixed SDP Transparent: “Can Direct Media” and “Auto Record” do not take effect in some cases 

¶ Fixed SDP Transparent: The INVITE forwarded from UCM should not carry feature code 

¶ Fixed SDP Transparent: Call fails or call hold behaves abnormal and call appears failure 

¶ Fixed SDP Transparent: In some case, UCM appears one-way audio issue when using Blind Transfer  

¶ Fixed SDP Transparent: UCM sends 488 Not Acceptable in certain scenario such as SRTP is 

enforced 
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¶ Fixed SDP Passthrough: UCM carries wrong c parameter when callee is registered with IPv4 and 

IPv6 address 

¶ Fixed Announcement Center: There is no recording file when the member selects “Auto Record” 

¶ Fixed Announcement Center: The ring timeout priority on extension setting should be lower than the 

setting in announcement center 

¶ Fixed Language: Wrong language prompt after the call is routed into DISA->IVR->Dial By Name 

¶ Fixed Language: Wrong language prompt when dialing feature code *11 or *12 via DISA 

¶ Fixed Firewall: Failed to disconnect TCP when IP is added to dynamic defense blacklist 

¶ Fixed Firewall: Suggest to add a prompt that the port must be ranging from small to large 

¶ Fixed SLA: 302 REDIRET message should not take effect when one station has call forward set to 

another station 

¶ Fixed SLA: Feature code should not send to SLA station 

¶ Fixed CDR: It would not generate CDR record after passive seamless transfer input timeout 

¶ Fixed CDR: Cannot download CDR records successfully by month in Automatic Downloading setting 

¶ Fixed Voicemail: Wrong prompt is played after after pressing 3 for advanced options 

¶ Fixed Voicemail: Cannot download voicemail attachment in mobile application 

¶ Fixed Warning: When Email sending mode is periodic, administrator receives mail delivery failure 

¶ Fixed Warning: UCM should generate alert log when SIP registration failed from the same account ID 

¶ Fixed User Management: SIP password can’t be changed when logging in user portal with extension 

number 

¶ Fixed Login Timeout: Login timeout is shown as a negative number 

¶ Fixed DHCPv6: Suggest to change T2 as 0.8 times of the Lease Time 

¶ Fixed IPv6: UCM should prompt error when setting IPv6 prefix length shorter than 64  

¶ Fixed SIP Settings: After enabling keep-alive, UCM will crash when caller and callee both perform call 

hold and then hang up 

¶ Fixed System Event: There is some error to detect coredump when coredump file is too big and 

detect cycle is too short 

¶ Fixed Syslog: There is no syslogd progress sometimes after enabling writing syslog into cache 

¶ Fixed Email: Display name shows incomplete when it has period to separate the name 

¶ Fixed After selecting factory menu to perform DSP test from LCD, it can’t go back to previous menu 

¶ Fixed LCD should display reading file error when uploading wrong file for firmware upgrading 

¶ Fixed Recording: CDR shows two identical recording files in certain scenario 

¶ Fixed TCP/TLS: The extension should show as unregistered after changing port of TLS and restarting 

¶ Fixed AMI: UCM takes wrong command and web UI will behave abnormally 

¶ Fixed Trunk: After UCM1 receives reboot event from UCM2 and responds 200OK, UCM1 is not 

rebooted 

¶ Fixed Blacklist: If there is already a blacklist including about 10000 numbers, it will take over 1 hour 

for uploading another blacklist with 200000 numbers 

¶ Fixed Cleaner: File clean time in the log has wrong time printed 

¶ Fixed Callback: Callback will ignore the outbound password when its destination is set to DISA 

¶ Fixed inbound call reaches voicemail and drops after 8 seconds 
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¶ Fixed Ring group extensions are not ringing in order if the ring group is invited to conference from 

web UI 

¶ Fixed Global/Model Template LDAP directory is using wrong values 

¶ Fixed Wrong trunk identification when using multiple trunks from the same provider 

¶ Fixed UCM will deny REINVITE which has no SDP with 488 response 

¶ Fixed The destination and gateway of IPv6 static route can’t input correctly 

¶ Fixed Reset/Reboot: PMS wakeup prompt appears abnormal after reset 

NEW FEATURES OVERVIEW 

This section lists major new features and describes how to use it from the user’s point of view. 

BLACKLIST/WHITELIST IN IVR 

In some scenarios, the IPPBX administrator needs to restrict the extension that can be reached from IVR. 

For example, the company CEO and directors prefer only receiving the call transferred by the secretary; 

some special extensions are used on IP surveillance end points which shouldn’t be reached from external 

calls via IVR for privacy reason. UCM has now added blacklist and whitelist in IVR settings for users to 

manage this. 

 

To use this feature, log in UCM web UI and navigate to PBX->Call Features->IVR->Create/Edit IVR: IVR 

Black/White List. 

¶ If the user selects “Blacklist Enable” and adds extension in the list, the extensions in the list will 

not be allowed to be reached via IVR. 

¶ If the user selects “Whitelist Enable” and adds extension in the list, only the extensions in the list 

can be allowed to be reached via IVR. 
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DOD IN PPI HEADER 

In UCM firmware prior to 1.0.13.14, if the user enables PPI header for VoIP trunk, P-Preferred-ID header 

in the INVITE will contain the registered username even if DOD has been configured for the VoIP trunk. 

On UCM 1.0.13.14, an option is added to allow user to choose whether to insert DOD or registered 

username in PPI Header. 

To use this feature, log in UCM web UI and navigate to PBX->Basic Call/Routes->VoIP Trunks->Edit 

Trunk->Advanced Settings: option “Send PPI Header” and “Use DOD in PPI”. When both options are 

enabled, if the user makes an external call from UCM extension via this trunk, in the INVITE message 

sent from the SIP trunk, the PPI header will include the configured DOD for this extension. 

 

 

PAI HEADER CUSTOMIZATION 

The UCM supports customize PAI header. This can be configured in UCM web UI->PBX->Basic 

Call/Routes->VoIP Trunks->Edit Trunk->Advanced Settings: option “Send PAI Header” and “PAI Header”. 

For example, if “Send PAI Header” is enabled and “PAI Header” is configured as “123456”, the PAI 

header in the SIP message sent from the UCM will contain “123456”. If “Send PAI Header” is enabled and 

“PAI Header” is configured as “empty”, the PAI header in the SIP message sent from the UCM will contain 

the original CID. 
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BLACKLIST FOR OUTBOUND CALLS 

On the UCM, users can configure blacklist for outbound route. If the dialing number matches the blacklist 

number or pattern, the outbound call will not be allowed. The outbound blacklist can be configured under 

UCM web UI->PBX->Basic Call/Routes->Outbound Routes: Outbound Blacklist. Users can configure 

number, pattern or select country code to add in the blacklist. 

 

Please note this blacklist setting applies to all outbound routes. 
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MOH UPLOAD/DOWNLOAD SUPPORT 

On UCM web UI->PBX->Internal Options->Music On Hold, users can upload music on hold files in a 

compressed package with .tar, .tar.gz and .tgz as the suffix. Click on the folder icon to select the package, 

then click on Upload to upload. This allows users to upload all music files at once. 

Users could also download all the music on hold files from UCM. In the Music On Hold page, click on 

“Download All Music On Hold” and the file will be downloaded to your local PC. 
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CUSTOM PROMPT DOWNLOAD SUPPORT 

On the UCM, the users can download all custom prompts from UCM web UI to local PC. To download all 

custom prompt, log in UCM web UI and navigate to PBX->Internal Options->Custom Prompt and click on 

“Download All Custom Prompt”. 

 

 

PROMPT WAIT TIME FOR DIAL BY NAME 

On the UCM, users can configure “Prompt Wait Time” for Dial By Name feature. During Dial By Name call, 

the caller will need input before this wait time is reached. Otherwise, timeout will occur and the call might 

hang up. 
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SEAMLESS TRANSFER PRIVILEGE CONTROL 

Starting from firmware 1.0.13.14, seamless transfer privilege control is working as follows. 

¶ On the UCM, if “Seamless Transfer” feature code is enabled (by default *44), any extensions on 

the UCM can perform seamless transfer.  

 

¶ If “Pickup Incall” feature is enabled (by default *45), only the extensions added in “Allowed to 

seamless transfer” in the extension’s Seamless Transfer Privilege Control List” can pick up the 

call. 
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RTP KEEP-ALIVE 

RTP Keep-Alive option can be found under UCM web UI->PBX->SIP Settings->ToS. It can be used 

to avoid abnormal call drop when the remote provider requires RTP traffic during proceeding. 

For example, when the call goes into voicemail and there is no RTP traffic sent out from UCM, configuring 

this option can avoid voicemail drop. 
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When it’s configured, RTP keep-alive packet will be sent to remote party at the configured interval. If set 

to 0, RTP keep-alive is disabled. 

EMAIL SEND LOG 

Under UCM web UI->Settings->Email Settings->Email Send Log, the users could search, filter and check 

whether the Email is sent out successfully or not. This page will also display the corresponding error 

message if the Email is not sent out successfully. 
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FIRMWARE VERSION 1.0.12.19 

 

PRODUCT NAME 

UCM6510 

DATE 

11/16/2016 

IMPORTANT UPGRADING NOTE 

¶ For UCM6510 that’s on 1.0.11.27 or above, please upgrade to 1.0.12.19 directly using the 

1.0.12.19 “ucm6500fw.bin” file.  Backup your data (including configuration) before firmware 

upgrade is recommended. 

 

¶ For UCM6510 that’s on 1.0.10.44, please upgrade to 1.0.11.27 first using the 1.0.11.27 

“ucm6500fw.bin” file, then upgrade to 1.0.12.19 using the 1.0.12.19 “ucm6500fw.bin” file.  The 

firmware upgrading process should be 1.0.10.44 -> 1.0.11.27 -> 1.0.12.19. Backup your data 

(including configuration) before firmware upgrade is recommended. 

 

¶ For UCM6510 that’s still on 1.0.2.7 (or lower), please follow upgrading instructions to upgrade 

to 1.0.12.19: 

 

- Backup, Backup, Backup, yes, backup your data (including configuration) before doing 

any firmware upgrade! An SD card or USB Flash Drive is needed for backup purpose.) 

- For UCM6510, upgrading from firmware version 1.0.2.7 (or lower) to firmware version 

1.0.12.19 directly is not supported. Please upgrade to 1.0.2.97, then 1.0.10.44 (in the 

firmware package) and then 1.0.11.27 (in the firmware package), before upgrading to 

1.0.12.19. The firmware upgrading process should be 1.0.2.7 (or lower) -> 1.0.2.97-> 

1.0.10.44 -> 1.0.11.27 -> 1.0.12.19. 

- The UCM6510 will be reset to factory default settings after upgrading to 1.0.11.27.  Users 

need restore backup file manually or re-configure after upgrade. Therefore, it is VERY 

IMPORTANT to manually BACKUP data on the UCM6510 before upgrade. Users will also be 

requested for backup when upgrading from 1.0.2.97 to 1.0.10.44. 

- Once upgraded to 1.0.12.19, downgrading to 1.0.2.7 (or lower) is not supported. 

 

UPGRADING INSTRUCTIONS 

The following are the upgrade steps from 1.0.2.7 to 1.0.12.19. 
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1. Upgrade UCM6510 from firmware 1.0.2.7 to 1.0.2.97 using the 1.0.2.97 “ucm6500fw.bin” file. 

2. When the UCM6510 is on firmware 1.0.2.97, open a web browser on a PC connected to the same 

network as UCM6510 to log in UCM6510 web UI. Go to Maintenance->Upgrade page, manually 

upload “ucm6500dpt.bin” file under Local Upgrade section from your PC. The “ucm6500dpt.bin” file 

can be found in the “Release_UCM6510_1.0.10.44.zip” folder in the firmware package. 

3. Once the UCM6510 finishes loading the ucm6500dpt.bin file successfully, it will reboot and 

automatically boot into recovery mode. 

4. In recovery mode, the UCM6510 LCD will display its IP address. Please type this IP address in the 

web browser of your PC that is connected to the same network as the UCM6510. Please make sure 

you have cleared your browser cache and type in IP address only (Do not specify protocol or port 

number). For example, if the IP address displayed in LCD is 192.168.1.2, please type in 192.168.1.2 

in the browser address bar. 

5. The following figure shows the UCM6510 web UI in recovery mode. Log in the UCM6510 as 

administrator. 

 

 

6. Once logged in (as shown in figure below), click on “Upload” and select firmware 1.0.10.44 

“ucm6500fw.bin” file from your PC to upload. 
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7. Please keep the web page open and wait until uploading is finished. Once done, an upgrading 

successful message will be prompted. 

 

 

8. On the recovery mode web UI, select “Reboot” to reboot the UCM6510. 

9. Your UCM6510 is successfully upgraded to 1.0.10.44. 

10. Please navigate to UCM6510 web UI, go to Maintenance->Upgrade page, manually upload firmware 

1.0.11.27 “ucm6500fw.bin” file to upgrade to 1.0.11.27. 

11. Once the UCM6510 finishes upgrading and boots up, log in UCM6510 web UI and navigate to 

Maintenance->Upgrade page, manually upload firmware 1.0.12.19 “ucm6500fw.bin” file to upgrade to 

1.0.12.19.  

 

CHANGES SINCE FIRMWARE VERSION 1.0.11.27 

ENHANCEMENT 

¶ Added Call-Info header in SIP INVITE message for auto-answer [CUSTOM CALL-INFO FOR AUTO 

ANSWER] 

¶ Added ability for users to select interval extensions in batch add extension [EXTENSION INTERVAL 

SETTING FOR BATCH ADDING EXTENSION] 

¶ Added support for Call-Barging feature in extensions [CALL-BARGING PRIVILEGE CONTROL] 

¶ Added support for mobile phone numbers to extensions [MOBILE PHONE NUMBER IN EXTENSION 

SUPPORTED] 

¶ Added support to batch add or update CallerID Number for extensions [BATCH ADD/UPDATE 

INTERFACE OF CALLERID NUMBER] 

¶ Added support for seamless transfer in extensions [EXTENSION SEAMLESS TRANSFER] 

¶ Added white list privilege in extensions for Do Not Disturb [WHITE LIST PRIVILEGE FOR DO NOT 

DISTURB] 

¶ Added string search option in extension [EXTENTION: STRING SEARCH SUPPORTED] 

¶ Added ability to allow outgoing calls without registration through register trunk [REGISTER TRUNK: 

ALLOW OUTGOING CALLS WITHOUT REGISTRATION] 

¶ Added option to append extension number at the end of DOD [APPEND EXTENSION NUMBER IN 

THE END OF DOD] 
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¶ Added ability for users to enable or disable inbound and outbound routes [ENABLE/DISABLE 

INBOUND AND OUTBOUND ROUTES] 

¶ Added support for time condition option in outbound rules [TIME CONDITIONS FOR OUTBOUND 

RULES ] 

¶ Added hotline option for FXS extensions [HOTLINE FOR FXS EXTENSIONS] 

¶ Added different algorithm methods for FXO testing [ACIM OPTION FOR FXO DETECTION] 

¶ Added FXO auto dial out function to troubleshoot analog trunks [FXO AUTO DIAL OUT] 

¶ Added ability for users to enable/disable extension ranges in setup wizard [DISABLE EXTENSION 

RANGES OPTION IN SETUP WIZARD] 

¶ Added support for CALL (CDR report) and MiniBar Options for hMobile [MINI BAR FOR PMS] 

¶ Added option to batch add rooms in PMS Room status [BATCH ADD ROOMS IN PMS] 

¶ Added feature code to support PMS wake up configuration [PMS WAKEUP SERVICE 

CONFIGURATION USING FEATURE CODE] 

¶ Added basic support for IPv6 (BETA) [BASIC IPV6 SUPPORT (BETA)] 

¶ Increased number of ports in port forwarding option to more than 8 ports [MORE PORTS 

SUPPORTED IN PORT FORWARDING] 

¶ Added ability to allow users to set MTU in Network settings [MTU SETTINGS] 

¶ Added support for SFTP data Sync for troubleshooting [SFTP DATA SYNC FOR ETHERNET 

CAPTURE] 

¶ Added ability for users to store troubleshooting files to external storages [STORE 

TROUBLESHOOTING FILES TO SD CARD/USB STORAGE DEVICE] 

¶ Added ability to clean up recorded files in external storage [CLEAN RECORDED FILES IN USB 

STORAGE DEVICE OR SD CARD] 

¶ Added support for special characters in firmware’s name [ALLOW SPECIAL CHARACTERS IN 

FIRMWARE FILE NAME] 

¶ Added ability for provision devices from different subnets in Zero Config [ZERO CONFIG: 

PROVISION DEVICE FROM DIFFERENT SUBNETS] 

¶ Added two digits support for Speed Dial [SUPPORT 2-DIGIT SPEED DIAL INSTEAD OF ONE-KEY 

DIAL] 

¶ Added support for CRM system to help users connect to Salesforce or SurgarCRM interface [CRM] 

¶ Added more search criteria for CDR Search [MORE SEARCH CRITERIA FOR CDR] 

¶ Added support for super administrator to create users with different customer privilege [SUPPORT 

SUPER ADMINISTRATOR ASSIGN CUSTOMPRIVILE] 

¶ Added ability for Super administrator to disable the custom privilege of deleting recording files 

[ENABLE DELETE RECORDING FILES IN CUSTOM PERIVILEGE] 

¶ Added feature code to configure wake up service [SET WAKEUP SERVICE BY FEATURE CODE] 

¶ Added ability to play Music on Hold in extensions through WebUI [PLAY MUSIC ON HOLD IN WEB 

UI] 

¶ Added display name to indicate the source of the call for RingGroup/CallQueue/IVR. [RING 

GROUP/CALL QUEUE/IVR DISPLAY OPTION FOR CALLERID] 
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¶ Added conference settings for UCM to detect talking users in the conference [UCM CONFERENCE 

SETTINGS] 

¶ Added iNode usage information [INODE USAGE INFORMATION] 

 

BUG FIX 

¶ Fixed Active Calls: Call failure caused by dialing *80/*81+paging/intercom 

¶ Fixed Active Calls: Call could be missed up when dialing voicemail 

¶ Fixed Alert: Failed subscribe of remote extension caused by wrong alert log 

¶ Fixed Announcements Center: Voice Prompt mistakenly recovered automatically 

¶ Fixed Asterisk_crash: Crash caused by change settings in TLS.ca/TLS/crt/TLS.key 

¶ Fixed Asterisk_crash: UCM crash when sync LDAP failure 

¶ Fixed Auto Recording: Inbound call displayed error callee number through the register trunk 

¶ Fixed Auto-Recording: CallerID set with special character caused auto record failure 

¶ Fixed Backup/Restore: Available disk space shown in WebUI not correct 

¶ Fixed Backup: Data Sync Log  record shows “uncompleted” and Data Sync failed in backup process 

¶ Fixed Backup: Backup Zero config data not take effect 

¶ Fixed Backup: Zero Config Model update package cannot be backup 

¶ Fixed Basic Call: Special character “;” in First Name and Last Name caused Caller name display error 

¶ Fixed Basic Call: CallerID Number caused recording voice prompt missing 

¶ Fixed Basic Call: Does not send the correct Request-Line header under specific cases 

¶ Fixed Basic Call: Error Extension status shown after call hanged up 

¶ Fixed Basic Call: Missing ringback tone when device was set Call Forward Unconditional to external 

number 

¶ Fixed Basic Call: Package header cannot update IP synchronously with UCM 

¶ Fixed Basic Call: Port range error from 1 to 65535 

¶ Fixed Basic Call: Setting name of TURN servers caused error warning  

¶ Fixed Basic Call: UCM crash caused by short time interval between SIP 200OK and 183 response 

¶ Fixed Basic Call: UCM not respond to INVITE caused by other network devices truncated message  

¶ Fixed BFCP: Range of UDP port number for BFCP not work 

¶ Fixed Call Park: The call park played ring back tong instead of MoH 

¶ Fixed Call Park: Parking options not take effected immediately when parking lots is using 

¶ Fixed Call Queue: Need a sign for suspended user 

¶ Fixed Call Queue: Voice Prompt for destination explanation not clear enough 

¶ Fixed Callback: Callback ignore the PIN Groups of outbound route when its destination is IVR 

¶ Fixed Callback: Inbound into IVR through peer trunk and entering feature codes ‘0#’ caused callback 

failure 

¶ Fixed Calling Rules: Should forbid to create members with same PIN Number in PIN Group 

¶ Fixed CDR: Bridging Multi-conference caused CDR display error 

¶ Fixed CDR: Call cannot produce CDR record in certain specific scenario 

¶ Fixed CDR: Call connected after parking caused CDR display error 
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¶ Fixed CDR: Call Forward Unconditional caused CDR display error 

¶ Fixed CDR: Call to IVR through the voicemail caused CDR display error 

¶ Fixed CDR: Call transfer caused CDR display error 

¶ Fixed CDR: Callee display error using Ring Group with simultaneously mode.  

¶ Fixed CDR: Caller display error when sending fax through Register SIP Trunk 

¶ Fixed CDR: CDR display error when Caller Number or Caller Name include “ ’ ” 

¶ Fixed CDR: CDR display error with calls through FXO inbound to FAX extension 

¶ Fixed CDR: CDR produce multiple records using WebUI to invite members to conference room 

¶ Fixed CDR: CDR wrong display when caller hang up the call before Voice Prompt 

¶ Fixed CDR: CDR_DISA caused CDR display error when caller return to dial and hang up 

¶ Fixed CDR: Conference Schedule in CDR display error 

¶ Fixed CDR: Dial by name caused CDR no answer status even through call is connected  

¶ Fixed CDR: Dial by name to outbound extension voicemail caused call type error 

¶ Fixed CDR: Dialing by DISA caused duplicate CDR recording File 

¶ Fixed CDR: Failed to delete recording files when 1% availability in CDR_Data Partition  

¶ Fixed CDR: Failed to use WebUI to invite a participant to conference would cause duplicate CDRs  

¶ Fixed CDR: Fax record lost issue in user portal page 

¶ Fixed CDR: Fax sending in CDR error display when enabled outbound route filter on Source Caller ID 

¶ Fixed CDR: FXS call to Fax extension caused CDR display error 

¶ Fixed CDR: FXS extension call other extensions through IVR caused CDR display error 

¶ Fixed CDR: Generate duplicated CDRs when using conference invite 

¶ Fixed CDR: Hang up the call before calling operator finish caused display error in CDR 

¶ Fixed CDR: Incorrect CDR status display when call connected extension in queue 

¶ Fixed CDR: Inviting invalid participant to conference caused CDR error display 

¶ Fixed CDR: Large amount of CDR caused error warning prompt when statistic table page changed to 

other pages 

¶ Fixed CDR: Out of order for attended transfer using feature code 

¶ Fixed CDR: Outbound Fax sending made Premier Caller empty 

¶ Fixed CDR: Press events to DISA in IVR caused CDR error display 

¶ Fixed CDR: Prompt “Failed to update data” when using CDR_API to set TLS bind IP address 

¶ Fixed CDR: Recording file failed when contains LDAP number in Ring Group 

¶ Fixed CDR: Showing multiple record files after transfer to Operator. 

¶ Fixed CDR: The callee number only record 30 bits 

¶ Fixed CDR: CDR cannot search numbers with special character ‘+’ 

¶ Fixed CDR: While CDR cleaned, the recording files not cleaned together 

¶ Fixed CID: CID shown “Asterisk” if set user’s name as ’\’ and left CID number empty 

¶ Fixed Concurrent User: Error warning prompt when the length of user name exceed six 

¶ Fixed Concurrent User: No notification email sent when admins change their passwords 

¶ Fixed Conference Schedule: cannot use invite function for users invited by CCM 

¶ Fixed Conference: Alert prompted “By Administration” in English while UCM’s system language is not 

English 
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¶ Fixed Conference: Caller still got ring back tone even through invited wrong extension number 

¶ Fixed Conference: Cannot delete conference room when setting its conference number as ‘0’ 

¶ Fixed Conference: Conference number starting with 0 caused conference option error in WebUI 

¶ Fixed Conference: Enable MCB caused record conference failed 

¶ Fixed Conference: Information of extension member did not update  

¶ Fixed Conference: Inviting outside number through WebUI caused the callerID display error 

¶ Fixed Conference: Need to implement a function for batch deleting large quantities of recording files 

¶ Fixed Conference: No check box for confirmation in inviting members 

¶ Fixed Conference: Not Google Calendar does not Sync with Conference Schedule  

¶ Fixed Conference: played conf-onlyperson.gsm after MCB with ordinary member in remote 

conference room 

¶ Fixed Conference: Pressing *84 caused UCM system crash 

¶ Fixed Conference: Record Conference not enabled when auto-record make MCB invite to another 

conference 

¶ Fixed Conference: UCM replied incorrect NOTIFY when client send update subscribe in Conference 

CEI 

¶ Fixed Conference: Using CCM to invite member by admin and re-enter the conference caused UCM 

reply 404 Not Found 

¶ Fixed Conference: Wrong voice prompted when users press *2 after admin press *83 

¶ Fixed Custom Prompts: Upload prompt unknown error occurred when the file contains “ ’ ” in the 

name 

¶ Fixed Dial-By-Name: failed to match when same extension in LDAP phonebook 

¶ Fixed disabled extensions receiving email from UCM 

¶ Fixed Dynamic Defense: User could not login when using IP address that deleted from blacklist 

¶ Fixed Email: Email Template Variables not work with subject 

¶ Fixed Email: Fax and Password email have extra picture attachment when using Outlook Express to 

check email 

¶ Fixed Email: SIP user ID not shown correctly in Email 

¶ Fixed Email: Subject could not be restored to default setting 

¶ Fixed Extension: Adding nine or ten local subnets with enabled “Show Advanced Options” caused 

abnormal display on WebUI 

¶ Fixed Extension: Cannot change “Auto Record” and “Language” in Batch process 

¶ Fixed Extension: Extension cannot be imported in some situation 

¶ Fixed Extension: In chrome browser, showing SIP/IAX password caused wrong display on Auth ID 

and Voicemail Password  

¶ Fixed Extension: Need to implement “add language option” in batch add extensions 

¶ Fixed Extension: Not allow special character ‘_’ in username of SIP register trunk 

¶ Fixed Extension: Special Character ‘<’,’>’ and ‘<>’ caused display error 

¶ Fixed Fail2ban: Cannot set -1 in banned duration of Fail2ban settings 

¶ Fixed Fax: Enable Jitter buffer caused failure of sending T38 

¶ Fixed Fax: No response for the 401 Challenge after T38 re-invite on incoming faxes 
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¶ Fixed Feature Code: Call forward Unconditional Deactivate not work 

¶ Fixed Feature Code: Call recover from parking could use feature code even through UCM disabled 

feature code 

¶ Fixed Feature Code: Modifying parking timeout while extension is parking caused Call Park 

unavailable 

¶ Fixed Feature Codec: Call Completion Request cannot start with **+number 

¶ Fixed FollowMe: FollowMe display error when two extensions ring simultaneously  

¶ Fixed FXS: Email does not contain name of FXS extension 

¶ Fixed FXS: Message Waiting tone will be prompt when the FXS hold the call 

¶ Fixed IAX: IAX Peer Trunk not send CID name when not check keep trunk CID 

¶ Fixed IE9: Access device page not available on Zeroconfig device list when using IE9 browser 

¶ Fixed IE9: Cannot show Zeroconfig update page in IE9 browser 

¶ Fixed Inbound route: The Caller number in blacklist caused repeat UCM voice prompt 

¶ Fixed Inbound Route: Using same outbound proxy caused call failure 

¶ Fixed Internal Options: Special Character ‘@’ and “ ’ ” caused error display in global outbound CID 

¶ Fixed IVR: No warning voice prompt when failed to play uploaded IVR files 

¶ Fixed IVR: The recording file missing caller and callee 

¶ Fixed Language: Call the trunk through DISA with Chinese Language setting, the voice prompt 

changed to English 

¶ Fixed Language: Urgent prompt do not support languages other than English 

¶ Fixed LDAP: Missing “Decrypt” button for root password 

¶ Fixed Log: Conference Schedule Member duplicated in Log 

¶ Fixed Log: Not log operation in deleting Alert log 

¶ Fixed Log: The operation log cannot record any changes of user information 

¶ Fixed Login: No limit times for entering wrong password 

¶ Fixed Monitor: Required to implement permission about monitor 

¶ Fixed Network: Port forwarding caused UCM login error 

¶ Fixed Network: Setting DHCP address pool caused DHCP Client lost 

¶ Fixed Network: Special character ‘ ” ’ in username and password of pppoe caused the network down 

¶ Fixed Network: UCM LAN address not able to be saved in the DHCP client list 

¶ Fixed Operation Log: Showing “Fromstring” instead of “Display Name” in Operation log 

¶ Fixed Outbound rule: Not allowed to set the pattern as '[N], [X], [Z]' 

¶ Fixed Outbound Rule: The warning prompt for repeat interval not work 

¶ Fixed Outbound: The inbound call ignore the PIN Group in certain specific scenarios 

¶ Fixed Paging/Intercom: Paging/Intercom succeed even through no member is included 

¶ Fixed Password: Checking password with clicking bulb sign caused password changed to “undefined” 

¶ Fixed PBX Status: Login as administrator caused PBX status missing 

¶ Fixed PMS: cannot enable wakeup service if non-numerical character contained in room number 

¶ Fixed PMS: CDR did not move to correct new extension after room changed 

¶ Fixed PMS: Incorrect Chinese translation in “Start Address Number” 



 

GRANDSTREAM NETWORKS                      UCM6510 RELEASE NOTE                                                                PAGE 28 

¶ Fixed PMS: Showing the added wakeup service info through WebUI need to manually refresh the 

page 

¶ Fixed PMS: The room and wakeup service not delete when deleting blinding extension 

¶ Fixed PMS: UCM reported wakeup status with wrong room number 

¶ Fixed PMS: UCM unable to send wake status after disabled wakeup feature code 

¶ Fixed PMS: Update for Check-in information on WebUI needs to be refreshed manually  

¶ Fixed PMS: Value of PMS URL could not be set as domain type 

¶ Fixed PMS: Voice prompt in PMS for room service do not have conformation update 

¶ Fixed PMS: Wakeup service could not be fully deleted 

¶ Fixed Queue: Chinese Voice prompt not clear for Queue 

¶ Fixed Queue: The retry time prompt warning display error when set Chinese Language in WebUI 

¶ Fixed Recording: Failed to record the analog call when it transferred to other extensions. 

¶ Fixed Recording: Missed caller and callee in recording file from callback 

¶ Fixed Recording: Missing caller and callee’s information for call back record 

¶ Fixed Ring Group: CallerID in LDAP number display error when set the Trunk CID 

¶ Fixed Ring Group: Error warning prompt when edit the extension with default destination to 

voicemail_extension of ring group 

¶ Fixed Ring Group: Inbound Calls through analog trunk failed to play Ring Group Custom Prompt 

¶ Fixed Ring Group: Option of Music on Hold mistakenly appeared after restore the ring group backup 

file 

¶ Fixed Ring Group: Ring Group displayed abnormal status without registered members. 

¶ Fixed Ring Group: Ring Group MoH not played on inbound calls through analog trunks 

¶ Fixed Setup Guide: Setup Wizard should not be shown in User Portal 

¶ Fixed Setup Wizard: Changes in Setup Wizard cannot be saved with IE browser. 

¶ Fixed SIP Settings: Setting bind IP address to WAN IP caused UCM cannot send Bye notification   

¶ Fixed SLA: 603 message caused UCM send incorrect notify state 

¶ Fixed System Event: Dialing extension and hang up before 480 caused system log missing 

¶ Fixed System Event: Edit current events caused previous event mistakenly changed 

¶ Fixed System Event: Email notification should not be enabled when alarm is disabled 

¶ Fixed System Event: Hanging up the call in WebUI caused duplicated alert log records 

¶ Fixed System Event: Need to implement a detect cycle in “Register SIP Failed” alert 

¶ Fixed System Event: No alert log when call failed caused by 603 declined 

¶ Fixed System Events: Error warning prompt when clicking Email Notification 

¶ Fixed TCP/TLS: deleting and then reloading TLS Cert/TLS Key caused export configuration failed. 

¶ Fixed Time Display: Time display error on WebUI 

¶ Fixed Trunk: CallerID Name in Trunk and Extension should have same limits 

¶ Fixed Trunk: DTMF method not being negotiated 

¶ Fixed Trunk: Outbound call failure when registered trunk enabled TEL URL and removed OBP from 

route 

¶ Fixed Trunk: Special Character in CallerID Name caused auto choose global outbound CID and name 

¶ Fixed Trunk: Suggested to optimize tips when enabled keep trunk CID but disabled config CallerID 
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¶ Fixed Trunk: Trunk status shown unmonitored after reboot with qualify enabled 

¶ Fixed Trunk: UCM respond 401 unauthorized when received option request didn’t match trunk 

¶ Fixed User Management: Login time mistakenly updated when reload the page 

¶ Fixed User Management: Operation log error display caused by reset the user data 

¶ Fixed User Portal: Listing files caused CGI crash 

¶ Fixed User Portal: Message display error 

¶ Fixed Voicemail: The reply option in voicemail caused error warning voice prompt in Peer Trunk users 

¶ Fixed Voicemail: Users could not delete their own recorded ‘unavailable message’ 

¶ Fixed Voicemail: Voicemail should be displayed based on its status in User Portal WebUI 

¶ Fixed Warning: “SIP peer trunk status” prompted multiple times 

¶ Fixed Warning: Alert Contact Email list can save same email address 

¶ Fixed Warning: Call Failure caused duplicated alert log records 

¶ Fixed Warning: Clicking Email notification caused error warning prompt 

¶ Fixed Warning: Disabling the alert caused login notification failed 

¶ Fixed Warning: Disk usage display error when it restored to normal 

¶ Fixed Warning: Error information displayed in waring message for Disk Usage and External Disk 

Usage 

¶ Fixed Warning: Normal Status of SIP Peer Trunk caused wrong alert 

¶ Fixed Warning: Sending Email error in Super Admin user when delete all email address in 

administrator users 

¶ Fixed Warning: The default detect cycle of memory usage is too short 

¶ Fixed Warning: UCM displayed duplicate waring logs when SIP internal call failed and received 408 

¶ Fixed Warning: Warning caused mailbox received duplicated Warning Emails  

¶ Fixed Warning: Warning Email destination not synchronized  

¶ Fixed Warning: Warning log display error in some situation  

¶ Fixed Warning: Warning logs printed duplicated SIP Peer Trunk Status  

¶ Fixed WebRTC: Hide the WebRTC anonymous config item in web page 

¶ Fixed ZeroConfig: DP750 Phonebook download protocol with error values 

¶ Fixed ZeroConfig: Incorrect SIP/RTP tooltip for DP750 Layer 3  

¶ Fixed ZeroConfig: Lost one P-value for DP750 Automatic Upgrade 

¶ Fixed ZeroConfig: Appeared save error prompt after uploaded firmware 

¶ Fixed ZeroConfig: Need to implement filed description on Softkey, Line keys and MPK 

¶ Fixed ZeroConfig: Unknown error prompt when using GXV3275 template to manage storage 

 

NEW FEATURES OVERVIEW 

This section lists major new features and describes how to use it from the user’s point of view. 

CUSTOM CALL-INFO FOR AUTO ANSWER 

The UCM6510 now supports to contain Call-info header indicating auto answer in the SIP INVITE 
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message for end devices. 

To configure this feature on extension, please navigate to UCM web UI-> PBX-> Extensions-> Create 

New SIP Extension/Edit Extension-> Features-> Other Settings-> Custom Call-info for Auto Answer. 

 

Steps to Use: 

1. Enable the Custom Call-Info for Auto Answer in extension. 

2. Register the extension to end device such as a GXP phone. 

3. Enable allow auto answer by call info on the end device so that the extension registered on the 

end device will auto answer incoming paging/intercom call. 
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MTU SETTINGS 

UCM6510 has allowed users to set MTU in the Network Setting for SIP Fragmentation.  

This option allows users to determine the maximum size of each packet in transmission to avoid losing 

package information. The range could be set between 1280 and 1500.  

To configure this feature, please navigate to UCM web UI-> Settings-> Network Settings-> Basic Settings-

> MTU. 
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MINI BAR FOR PMS 

UCM6510 added Mini Bar in PMS to control consumer goods management in each Room. This feature 

can be found in UCM web UI-> PBX-> PMS-> Mini Bar. 

 

DISABLE EXTENSION RANGES OPTION IN SETUP WIZARD  

UCM6510 allows users to disable extension ranges in the Setup Wizard Page.   

Once this feature is enabled, users do not need to follow extension ranges set by UCM.  

To configure this feature, please navigate to UCM web UI-> Setup Wizard-> Extensions-> Disable 

Extension Range. This option is also available in PBX->Internal Options->General. 

 

SFTP DATA SYNC FOR ETHERNET CAPTURE 

UCM6510 allows users to save capture files in the SFTP server. Instead of manual downloading, Ethernet 

capture can now be directly synced to pre-configured SFTP server. Please make sure the configuration of 

data synchronization works before enabling this function. To configure this feature, please navigate to: UCM 

web UI-> Maintenance-> Troubleshooting-> Ethernet Capture-> Enable SFTP Data Sync. 



 

GRANDSTREAM NETWORKS                      UCM6510 RELEASE NOTE                                                                PAGE 33 

 

To configure the data Sync, please navigate to UCM web UI-> Maintenance-> Backup-> Data Sync -> 

Manage Data Sync. Please enter the basic information of your SFTP server in corresponding fields. The 

Sync Time is the start time for auto Sync. 

 

After SFTP server configuration, click on “Test Connections”. If the UCM6xxx can connect to SFTP server, 

users can see a prompt “SFTP backed up successfully”. 
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BATCH ADD ROOMS IN PMS 

UCM6510 provides batch add rooms for PMS support.  

This feature allows users to add multiple rooms based on current available extensions at once.  

To configure this feature, please navigate to UCM web UI-> PBX-> PMS-> Room Status-> Batch Add 

Rooms. 

 

 

After Click on “Batch Add Rooms”, it will prompt a window like below. Please enter the start address 

number and start room number you want to create in corresponding fields. 

 

HOTLINE FOR FXS EXTENSIONS 

UCM6510 now allows users to enable hot-line function for FXS extension.  

There are two modes for hotline Type:  

1. Immediate Hotline: UCM will dial the number immediately after the FXS extension is off-hook. 

2. Delay Hotline: UCM will wait for 5 seconds after off-hook and then dial the number. 
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This feature can be found in UCM web UI-> PBX->Basic->Extensions->Create New FXS 

Extension/Modify FXS Extension->Features-> Hotline. 

 

MORE PORTS SUPPORTED IN PORT FORWARDING 

The UCM6510 now allows users to add more than 8 entries for port forwarding in network settings.  

Currently the number of port forwarding is not limited. 

To configure this feature, please navigate to UCM web UI-> Settings-> Network Settings-> Port 

Forwarding-> Create New Port Forwarding. 

 

CALL-BARGING PRIVILEGE CONTROL 

UCM6510 now supports call-barging privilege settings. Only the extension added in the “Allowed to call-
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barging” list can barge in active calls. To configure this feature, please navigate to UCM6XXX web UI-> 

PBX->Extensions-> Create or Edit Extension-> Features-> Monitor privilege control. Select available 

extensions from left and click “>” to right field. The extensions in “Selected Extensions” field can barge in 

active calls on the edited extension. 

 

Users could enable spy and set the Feature code in PBX-> Internal Options-> Feature Codes. By calling 

the corresponding code, user could active the following barge-in functions: 

1. Listen Spy: the user will be muted and he/she can listen to both caller and callee 

2. Whisper Spy: The user can listen and talk to one party in the active call 

3. Barge Spy: The user can listen and talk to all parties in the active call. 
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ENABLE/DISABLE INBOUND AND OUTBOUND ROUTES 

The UCM has option for users to disable/enable the specific Inbound/Outbound Routes. When disabling 

the inbound/outbound, the corresponding rule will not work but its settings will remain in case it needs to 

be enabled for future usage.  

To configure this feature in inbound side, please navigate to UCM6XXX web UI-> PBX->Basic -> Inbound 

Routes-> Create New Inbound Rule/Edit Inbound Rule-> Disable this Route. 

 

 

To configure this feature in outbound side, please navigate to: UCM web UI-> PBX->Basic -> Outbound 

Routes-> Create New Outbound Rule/Edit Outbound Rule-> Disable this Route. 
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STORE TROUBLESHOOTING FILES TO SD CARD/USB STORAGE DEVICE 

UCM6510 now allows users to store the troubleshooting files to External Devices such as USB or SD 

Card. To configure this feature, please navigate to UCM web UI-> Maintenance-> Troubleshooting-> 

Ethernet Capture-> Storage to External Device. 
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EXTENSION INTERVAL SETTING FOR BATCH ADDING EXTENSION 

The UCM6510 allows users to configure extension intervals in batch add Extension.  

For example, users can set the value to 2 if they want to batch add extensions like 1000, 1002, 1004...  

To configure this feature, please navigate to UCM6XXX web UI-> PBX-> Basic-> Extensions-> Batch Add 

SIP Extensions-> Extension Interval. 

 

 

MOBILE PHONE NUMBER IN EXTENSION 

The UCM6510 supports binding a mobile phone numbers to extensions.  

Steps to Use: 

Users dial the feature code *88 + extension number. 

If the extension has set the Mobile Phone Number, the call will connect to the mobile number directly.  

To configure this feature, please navigate to UCM6XXX web UI-> PBX-> Basic-> Extensions-> Create a 

New Extension/Edit Extension-> Basic Setting-> Mobile Phone Number.  
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ALLOW SPECIAL CHARACTERS IN FIRMWARE FILE NAME 

UCM6510 now supports special characters in firmware file name. Users could use special characters like 

“_@#*~&” in the file name. 
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SUPPORT 2-DIGIT SPEED DIAL INSTEAD OF ONE-KEY DIAL 

The UCM6510 has now replaced One-Key-Dial to Speed Dial in order to support more than one digit 

speed dials.  

 

To configure this feature, please navigate to UCM6XXX web UI-> PBX-> Call Features-> Speed Dial. 

 

 

FXO AUTO DIAL OUT 

The UCM6510 now supports A Key Dial-up in FXO to help users trouble shooting analog trunks.   

 

Please configure outbound route for Analog Trunk firstly. Users can enter the phone number in External 

Extension and press Start button to start the FXO test. The call will be connected after click the “Start” 

button. Please answer and finish the call before press the “Stop” button. The trace will be available to 

download when output result shows” Done! Click on Download to download the captured packets”. 

 

To configure this feature, please navigate to UCM web UI-> Maintenance-> Troubleshooting-> Analog 

Record Trace-> A key Dial up FXO. 

 

BATCH ADD/UPDATE CALLERID NUMBER FOR EXTENSIONS 

UCM6510 now has supported users to batch add or update the CallerID Number for extensions. To 

configure this feature, please navigate to UCM6XXX web UI-> PBX-> Basic-> Batch Add SIP Extensions-

> CallerID Number. 
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CRM 

UCM6510 now supports CRM System to help users connect 3rd party’s CRM interfaces. CRM stands for 

Customer Relationship Management. Users can select to save the unknown number to Contact, Leads or 

Accounts. Currently UCM supports Salesforce CRM and SugarCRM. To configure this feature, please 

navigate to UCM web UI-> PBX-> CRM-> Basic Settings. 
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To configure CRM for Salesforce: 

1. Apply a development account in Salesforce. 

2. Acquire Security Token for your account. 

3. Set up the basic setting in CRM. 

 

4. Set the CRM security token in User Portal. (User Portal-> Value-added Features-> CRM User 

Settings). The Login Status will show “Logged in” if input correctly. 

 

 

To configure SugarCRM, please setup the SugarCRM server and configure it with IP address in 

UCM6510. 
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MORE SEARCH CRITERIA FOR CDR 

UCM6510 has supported search criteria such as Status, Account Code and Action Type for CDR. To use 

this feature, please navigate to UCM web UI-> Status-> CDR-> CDR. 

Users could  

1. Select Action type as Dial/Announcements/Callback to filter the calls. 

2. Select Status as Answered/No Answer/ Busy/Failed to filter the calls 

 

 

TIME CONDITIONS FOR OUTBOUND RULES 

UCM6510 now supports to add time conditions for the outbound Rules. 
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Users could choose Holiday/Office time or a Specified time to use the corresponding Outbound Rule.  

To configure this feature, please navigate to UCM web UI -> PBX-> Basic/Call Routes-> Outbound 

Routes-> Create new outbound rule/Edit outbound roles-> Time Condition. 

 

 

BASIC IPV6 SUPPORT (BETA) 

UCM6510 now supported Internet Protocol version 6 for IP address. 

Users can check the IPv6 address information on UCM6XXX WebUI-> Status-> System Status-> 

Network-> IPv6 Address.  

 

Users can access UCM6XXX WebUI by enter https://[IPv6_address]:8089/  

https://[IPv6_address]:8089/
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To register SIP extension, please choose Prefer IPv6 in Network setting and reboot the phone. The format 

to enter in SIP server of account should be [IPv6_address] 

 

IPv6 configuration can be found under UCM webUI->Settings->Network Settings->Basic Settings     -

>Click on “IPv6 Address” tab. 

 

 

ACIM OPTION FOR FXO DETECTION 

UCM6510 now supports users to select different test methods for FXO.  
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UCM currently supports the ERL algorithm and Pr algorithm Testing. 

To configure this feature, please navigate to UCM web UI -> PBX-> Ports Config-> Analog Hardware-> 

FXO Ports Edit-> Detect Option. Users could select different detect methods. 

 

EXTENSION SEAMLESS TRANSFER 

UCM6510 now supports seamless transfer for extensions so that users could transfer their calls to other 

devices seamlessly without Music on Hold presented to the other party.  

To configure this feature, please navigate to UCM6XXX web UI -> PBX-> Basic -> Extensions -> Edit 

Extension/ Create a new Extension-> Features-> Other Settings -> Enable Seamless Transfer. 
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PMS WAKEUP SERVICE CONFIGURATION USING FEATURE CODE 

UCM6510 supports users to configure wakeup service by using the feature code *35. To configure this 

feature, please navigate to UCM web UI -> PBX-> Internal Options-> Feature Codes-> PMS Wakeup 

Service. Users could enable this function by clicking the box next to the code field. 

 

SUPPORT SUPER ADMINISTRATOR ASSIGN CUSTOM PRIVILEGE 

UCM supports Super Administrator to create new users with customized privileges.  

Usage: Super Admin could provide different users with different roles to manage UCM6XXX.  

To create custom privilege, please navigate to: UCM6XXX web UI -> Settings-> User Management-> 

Custom Privilege-> Create New Custom Privilege. 

 

To assign privilege to specific user, please navigate to: UCM6XXX web UI -> Settings-> User 

Management-> User Information-> Create New User/Edit Users-> Privilege. 
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INODE USAGE INFORMATION 

UCM6510 now displays the information of inode usage in the page of system usage. To check the Inode 

status, please navigate to UCM6XXX web UI -> Status-> System Status-> Storage Usage-> Inode Usage. 

 

 

SET WAKEUP SERVICE BY FEATURE CODE 

UCM6510 supports users to set up wakeup service by using the feature code *36. Please follow the IVR 

to set up the wakeup service. The Date format should be YYYY-MM-DD. The Time format should be: HH-

MM. To configure this feature, please navigate to UCM6XXX web UI -> PBX-> Internal Options-> Feature 
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Codes-> Wakeup Service. Users could enable this function by clicking the box next to the feature code. 

 

REGISTER TRUNK: ALLOW OUTGOING CALLS WITHOUT REGISTRATION 

UCM6510 supports users to allow outgoing calls if there is registration failure in register trunk. To 

configure this feature, please navigate to UCM6XXX web UI -> PBX -> Basic/Call Routes-> VoIP Trunks-

> Create New SIP Trunk-> Type: Register SIP Trunk-> Allow outgoing calls if registration failure. 
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PLAY MUSIC ON HOLD IN WEB UI 

UCM6510 has supported playing music on hold after accessing webUI. Users could hear the music from 

extension after clicking ‘play’ button and configuring the extension on the WebUI. To configure this 

feature, please navigate to UCM web UI -> PBX -> Internal Options-> Music on Hold -> List of Sound 

Files-> Play. 

 

SEARCH EXTENSIN USING CALLERID NAME  

UCM supports String search for CallerID Name. To configure this feature, please navigate to UCM web UI -> 

PBX-> Extensions-> CallerID Name. 

 

CLEAN RECORDED FILES IN USB STORAGE DEVICE OR SD CARD 

UCM6510 supports to clean up recorded files in USB or SD card through the Web UI. Select the desired 
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directory “Directory” option.  

Users will see a list of files displayed. Select the files and click on “Delete Selected File” to remove them 

from the storage device. To configure this feature, please navigate to UCM6XXX web UI -> Maintenance -> 

Cleaner-> USB/SD Card Files Cleanup. 

 

 

APPEND EXTENSION NUMBER IN THE END OF DOD 

UCM now allows users to append the extension number after the DOD in order to show unique 

extensions. To configure this feature, please navigate to UCM web UI -> PBX-> Basic-> VoIP Trunks -> 

DOD-> Create a new DOD -> Add Extension. 
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WHITE LIST PRIVILEGE FOR DO NOT DISTURB 

UCM6510 has added DND whitelist for extension. When DND is enabled for an extension on UCM, this 

extension could still accept calls from DND Whitelist. The maximum number for DND White list is 10. To 

configure this feature, please navigate to UCM6XXX web UI -> PBX-> Extensions-> Create a New 

Extension/Edit Extension -> Feature-> Do Not Disturb -> DND Whitelist. Users could configure the 

numbers in the DND Whitelist. 
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ENABLE DELETE RECORDING FILES IN CUSTOM PRIVILEGE 

UCM6510 allows Super administrator to disable the custom privilege of deleting their own recording files 

in user level login. To configure this feature, please navigate to UCM web UI -> Settings-> Custom Privilege-

> General_User -> Edit-> Enable Delete Recording Files. 

 

 

If Super Administrator disable this item, users could not delete the recording files in User level login: 

 

 

 

ZERO CONFIG: PROVISION DEVICE FROM DIFFERENT SUBNETS 

UCM6XXX now supports Zero Config to provision devices from different subnets. To configure this feature, 

please navigate to UCM6XXX web UI -> PBX-> Zero Config-> Zero Config Settings -> Network Settings-> 

Subnet Whitelist. 

 

Steps:  

1. Put device and UCM6XXX in the same subnet and use Zero Config to provision the device. 

2. Put the device to another subnet and add that subnet to “Whitelist Subnets” in Zero Config 

Settings. 

3. Now the phone in a different subnet which is already in the whitelist can still be edited from UCM 

zero config. 
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RING GROUP/CALL QUEUE/IVR/DISPLAY OPTION FOR CALLER ID 

UCM6510 now supports users to enable “Replace Caller ID” in Ring Group/ Call Queue/ IVR. If enabled, 

the caller’s caller ID will be replaced with Ring Group, Call Queue or IVR name. This feature allows the 

callee to see whether the call is from the extension directly or dialed from Ring Group, Call Queue or IVR.  

 

To configure this feature in Ring Group, please navigate to UCM6XXX web UI -> PBX-> Caller Features -

> Ring Group -> Replace Caller ID. 

 

 

To configure this feature in Call Queue, please navigate to UCM6XXX web UI -> PBX-> Caller Features -

> Call Queue -> Replace Caller ID. 

 

 

To configure this feature in Ring Group, please navigate to UCM6XXX web UI -> PBX-> Caller Features -

> IVR -> Replace Caller ID. 



 

GRANDSTREAM NETWORKS                      UCM6510 RELEASE NOTE                                                                PAGE 56 

 

 

UCM CONFERENCE SETTINGS 

UCM6510 implemented Conference Settings in the Conference. Users can check the talking Caller IDs in 

conference control page (UCM WebUI-> Call Features-> Conference). The image will move up and down 

when the user is talking. 

 

To configure this feature, please navigate to: UCM WebUI-> Call Features-> Conference-> Conference 

Settings. 

 

 
 

¶ Enable Talk Detection: Users can enable the talk detection by clicking this box.  

¶ DSP Talking Threshold: The continuous time in millisecond to change user status to talk. The 
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default value is 128. 

¶ DSP Silence Threshold: The continuous time in millisecond to change user status to silent. The 

default value is 2500. 
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FIRMWARE VERSION 1.0.11.27 

 

PRODUCT NAME 

UCM6510 

DATE 

08/02/2016 

IMPORTANT UPGRADING NOTE 

¶ For UCM6510 that’s already on 1.0.10.44, please upgrade to 1.0.11.27 directly using the 

1.0.11.27 “ucm6510fw.bin” file.  

 

¶ For UCM6510 that’s still on 1.0.2.7 (or lower), please follow upgrading instructions to upgrade 

to 1.0.11.27. 

 

¶ Backup, Backup, Backup, yes, backup your data (including configuration) before doing any 

firmware upgrade!  (An SD card or USB Flash Drive is needed for backup purpose.) 

 

¶ For UCM6510, upgrading from firmware version 1.0.2.7 (or lower) to firmware version 1.0.11.27 

directly is not supported. Please upgrade to 1.0.2.97 and then 1.0.10.44 (in the firmware 

package), before upgrading to 1.0.11.27. The firmware upgrading process should be 1.0.2.7 (or 

lower) -> 1.0.2.97-> 1.0.10.44 -> 1.0.11.27. 

 

¶ The UCM6510 will be reset to factory default settings after upgrading to 1.0.11.27.  Users need 

restore backup file manually or re-configure after upgrade. Therefore, it is VERY IMPORTANT 

to manually BACKUP data on the UCM6510 before upgrade. Users will also be requested for 

backup when upgrading from 1.0.2.97 to 1.0.10.44. 

 

¶ Once upgraded to 1.0.11.27, downgrading to 1.0.2.7 (or lower) is not supported. 

 

 

UPGRADING INSTRUCTIONS 

The following are the upgrade steps from 1.0.2.7 to 1.0.11.27. 

 

1. Upgrade UCM6510 from firmware 1.0.2.7 to 1.0.2.97 using the 1.0.2.97 “ucm6500fw.bin” file. 
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2. When the UCM6510 is on firmware 1.0.2.97, open a web browser on a PC connected to the same 

network as UCM6510 to log in UCM6510 web UI. Go to Maintenance->Upgrade page, manually 

upload “ucm6500dpt.bin” file under Local Upgrade section from your PC.  

3. Once the UCM6510 finishes loading the ucm6500dpt.bin file successfully, it will reboot and 

automatically boot into recovery mode. 

4. In recovery mode, the UCM6510 LCD will display its IP address. Please type this IP address in the 

web browser of your PC that is connected to the same network as the UCM6510. Please make sure 

you have cleared your browser cache and type in IP address only (Do not specify protocol or port 

number). For example, if the IP address displayed in LCD is 192.168.1.2, please type in 192.168.1.2 

in the browser address bar. 

5. The following figure shows the UCM6510 web UI in recovery mode. Log in the UCM6510 as 

administrator. 

 

 

6. Once logged in (as shown in figure below), click on “Upload” and select firmware 1.0.10.44 

“ucm6500fw.bin” file from your PC to upload. 

 
 

7. Please keep the web page open and wait until uploading is finished. Once done, an upgrading 

successful message will be prompted. 
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8. On the recovery mode web UI, select “Reboot” to reboot the UCM6510. 

9. Your UCM6510 is successfully upgraded to 1.0.10.44. 

10. Please navigate to UCM6510 web UI, go to Maintenance->Upgrade page, manually upload firmware 

1.0.11.27 “ucm6500fw.bin” file to upgrade to 1.0.11.27.  

 

CHANGES SINCE FIRMWARE VERSION 1.0.10.44 

ENHANCEMENT 

¶ Added ability to sort extension status on web UI [EXTENSION STATUS IMPROVEMENT] 

¶ Added one click enable / disable feature code [FEATURE CODE SELECTION IMPROVEMENT] 

¶ Added Uruguay time zone support [URUGUAY TIME ZONE SUPPORT] 

¶ Added distinctive ring tone support [DISTINGCTIVE RING TONE SUPPORT] 

¶ Added special character support for SFTP client account [SFTP CLIENT ACCOUNT SPECIAL 

CHARACTRE SUPPORT] 

¶ Added destination directory support for data sync [DESTINATION DIRECTORY] 

¶ Added ring group music on hold [RING GROUP MUSIC ON HOLD] 

¶ Added CDR multi-email / time condition support [CDR MULTI EMAIL AND SPECIFIC TIME 

DOWNLOAD SUPPORT] 

¶ Added blacklist anonymous call block [BLACKLIST ANONYMOUS CALL BLOCK] 

¶ Added ability to sort selected extension in eventlist [EVENTLIST: SORTING SELECTED 

EXTENSION] 

¶ Added banned user list for web UI login attempts [WEB UI LOGIN IMPROVMENT] 

¶ Added Email template support [EMAIL TEMPLATE] 

¶ Added outbound route country restriction [OUTBOUND ROUTE: COUNTRY RESTRICTION] 

¶ Added external disk usage alert option [EXTERNAL DISK USAGE ALERT] 

¶ Added range IP input support for dynamic defense white list [DYNAMIC DEFENSE: WHITE LIST 

RANGE IP SUPPORT] 

¶ Added blacklist support for Fail2ban [FAIL2BAN: BLACKLIST] 

¶ Added ability to reboot device from zero config page [ZERO CONFIG: REBOOT DEVICE] 

¶ Added GXP1628B template for zero config [ZERO CONFIG: GXP1628B SUPPORT] 
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¶ Added PIN group support [PIN GROUP SUPPORT] 

¶ Added H-Mobile PMS support [H-MOBILE PMS SUPPORT] 

¶ Added call queue custom prompt support [CALL QUEUE: CUSTOM PROMPT] 

¶ Added call queue retry time support [CALL QUEUE RETRY TIME] 

¶ Added enhancement for anonymous call on SIP trunk [ADDED ENHANCEMENT FOR ANONYMOUS 

CALLS ON SIP TRUNK] 

¶ Added "call-info" SIP header for GXP phone paging mode [ADDED KEEP THE “CALL-INFO” SIP 

HEADER FROM GXP PHONE USING PAGING MODE] 

¶ Added authentication for inbound SIP INVITE  from SIP trunk (for Broadworks) 

BUG FIX 

¶ Fixed PJSIP pool caused crashing issue 

¶ Fixed Service check function doesn’t work issue 

¶ Fixed CDR auto download by month CSV file empty issue 

¶ Fixed CDR API Sub_CDR_1 field is duplicate on JSON file 

¶ Fixed Trunk caller ID name only allow to input letter, digits and space 

¶ Fixed Trunk call back auto recording file abnormal issue 

¶ Fixed Trunk call back auto recording doesn’t play prompt issue 

¶ Fixed Trunk call back only has Chinese and English voice prompt 

¶ Fixed Trunk DOD tooltips unclear issue 

¶ Fixed Trunk incoming call drops in 30 seconds 

¶ Fixed Trunk call back using failover trunk on outbound call will fail 

¶ Fixed Trunk caller ID with special characters will cause UCM crash 

¶ Fixed Trunk inbound route blacklist doesn’t block call correctly issue 

¶ Fixed Trunk inbound route mode 1 strip value is null 

¶ Fixed Trunk inbound route privilege level is hidden when dial trunk is enabled 

¶ Fixed Trunk inbound call transfer fails with NEXTIVA trunk when PAI is enabled 

¶ Fixed Trunk: inbound route black list feature code prompt doesn’t match status issue 

¶ Fixed Trunk: disable qualify will cause outbound call fail 

¶ Fixed Trunk: outbound route custom dynamic route tooltips 

¶ Fixed Trunk: outbound route custom dynamic route cannot display full details when it is too long 

¶ Fixed Register Trunk SIP message abnormal behavior issue when “TEL URI” option is enabled 

¶ Fixed Register Trunk NAT tooltips misleading issue 

¶ Fixed Register Trunk extension NAT option does not take effect when transport set to TCP 

¶ Fixed Register Trunk will switch to alternative IP when UCM receives any 5xx and 6xx response 

¶ Fixed Register Trunk: UCM doesn’t send registration update at desired timer 

¶ Fixed Register Trunk: UCM doesn’t send correct caller ID and name  

¶ Fixed Callback outbound password doesn’t take effective when using DISA in callback 

¶ Fixed Active Call page will display incorrect call forward status when “Auto Record” is enabled 

¶ Fixed Active Call page will display incorrect call log when two extensions dial to parking lot 
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¶ Fixed Active Call page will generate two call records when answering ring group calls using feature 

code 

¶ Fixed Active Call page will display incorrect extension when call forward is enabled 

¶ Fixed Active Call page abnormal display when calling into paging / intercom extension 

¶ Fixed Active Call callee carries caller’s caller ID name for CC feature 

¶ Fixed Active Call page fax extension display issue 

¶ Fixed Active Call page IAX extension callee ID and name display issue 

¶ Fixed Active Call page doesn’t display corresponding spy mode 

¶ Fixed Active Call will display callee as unknown when using one key dial to reach voicemail 

¶ Fixed Active Call page will display two records when follow me members enable auto recording 

¶ Fixed Active Call page display issue after clicking Apply Changes 

¶ Fixed Active Call page cannot hangup when monitored extension becomes abnormal 

¶ Fixed Active Call page display issue when callee enables ring both 

¶ Fixed Active Call page display issue when a call is transferred to call queue operator extension 

¶ Fixed Active Call page display issue when call queue or ring group has IAX extension member 

answers the call 

¶ Fixed Active Call FXO port shows in use when removing PSTN line from UCM 

¶ Fixed Active Call doesn’t have error prompt when monitoring non registered extension 

¶ Improved Active Call page display for transfer call 

¶ Improved Active Call page display for direct dial extension when calling through register trunk 

¶ Fixed CDR display issue when CCSS call is rejected 

¶ Fixed CDR caller number tooltips error 

¶ Fixed CDR MCB invite doesn’t have independent record 

¶ Fixed CDR and voice recording not show callee  issue if analog line has no CID 

¶ Fixed CDR inbound route mode 1 will have incorrect record 

¶ Fixed CDR recording stops after a call is parked 

¶ Fixed CDR incorrect record when dialing FXS extension through paging / intercom group 

¶ Fixed CDR incorrect record when using follow me for remote extension 

¶ Fixed CDR cannot display ring group record when all members in the ring group rejects the call 

¶ Fixed CDR cannot display trunk name when inbound call coming through analog / digital trunk 

¶ Fixed CDR: GXP2160 doesn’t generate record when using line button to dial 

¶ Fixed CDR: invite IAX / FXS extension into conference room will have extra CDR record 

¶ Fixed CDR incorrect record for call queue members 

¶ Fixed CDR display error when filter using SIP call 

¶ Fixed CDR incorrect record when calling into IVR has no extension number 

¶ Fixed CDR peer / IAX trunk will generate two records 

¶ Fixed CDR generates two records when follow me member has FXS / IAX extension 

¶ Fixed CDR callee displays as ‘s’ when it is a FAX extension coming through IVR 

¶ Fixed CDR search result doesn’t match search settings 

¶ Fixed CDR doesn’t generate record when using FXS extension 

¶ Fixed CDR will display no call detail if call prefix contains character ‘#’ 
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¶ Fixed CDR display issue when user calls conference room 

¶ Fixed CDR display issue when creating customized prompt 

¶ Fixed CDR display issue when ring simultaneously for external number is enabled 

¶ Fixed CDR display issue when using dial by name on inbound call 

¶ Fixed CDR doesn’t have call details when using AMI command originate calls 

¶ Fixed CDR FXS extension ring simultaneously will have incorrect record when ring simultaneously is 

enabled 

¶ Fixed CDR will have incorrect record when inbound call to external number 

¶ Fixed CDR: Chinese caller ID name will cause CDR record missing 

¶ Fixed CDR: incoming call from analog trunk without CID will cause no CDR and voice record 

¶ Fixed CDR API: setting TLS bind address to IP or domain will cause error prompt issue 

¶ Fixed CDR API: cannot delete permitted IP address 

¶ Fixed CDR API: Sub_CDR_1 field is duplicated in download JSON file 

¶ Fixed Extension Can Reinvite tooltips issue 

¶ Fixed Extension Caller ID Name option incorrect tooltips issue 

¶ Fixed Extension enable WebRTC option language error 

¶ Fixed Extension: cannot reboot phone when AuthID is different than Extension number 

¶ Fixed Extension: incorrect WebRTC option in IAX and FXS extension page 

¶ Fixed IAX Extension: batch add IAX extension shows “wrong account or password” 

¶ Fixed IAX and FXS extension does not send account name when using Email to User 

¶ Fixed FXS extension voicemail doesn’t require password issue 

¶ Fixed FXS extension web page error prompt when modifying analog station 

¶ Fixed FXS Hotline option doesn’t have default value 

¶ Fixed FXS echo canceler doesn’t work on flash dial 

¶ Fixed Basic Call wrong CID for internal calls when Ring Simultaneously is enabled 

¶ Fixed Basic Call drops because SIP INFO is rejected by UCM 

¶ Fixed Basic Call ring simultaneously with external number will cause CID display issue 

¶ Fixed Basic Call cannot record 3-way conference 

¶ Fixed Basic Call cannot use feature code *0 to cancel attend transfer 

¶ Fixed Basic Call error prompt when using feature code *40 to add blacklist 

¶ Fixed Basic Call attend transfer Chinese language prompt error 

¶ Fixed Basic Call: parking call in occupied parking lot will connection two calls together 

¶ Fixed Basic Call: UCM cannot differentiate a call received on specific inbound route 

¶ Fixed Basic Call: extension will have abnormal status when previously delete and re-create the same 

extension 

¶ Fixed Basic Call: UCM cannot display extension status correctly when extension re-register on UCM 

¶ Fixed Basic Call: UCM cannot display extension status correctly after UCM reboots 

¶ Fixed Basic Call: video call with different codec will cause preview display abnormal 

¶ Fixed Basic Call: codec negotiation will fail if UCM has 183 response 

¶ Fixed Basic Call: cancel call from caller side when callee enables unconditional forward will cause 

UCM crash 
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¶ Fixed Basic Call: blind transfer will cause UCM to display incorrect caller ID 

¶ Fixed Basic Call: CCSS fail to call back when TEL URL via trunk is enabled 

¶ Fixed Basic Call: CCSS publish message exception caused system crash 

¶ Fixed Basic Call: UCM doesn’t use same codec from negotiation when receiving 183 response 

¶ Fixed Basic Call: caller ID number will cause CCSS fail 

¶ Fixed Basic Call: time condition doesn’t take effect 

¶ Fixed Basic Call: hold call feature issue  

¶ Fixed BLF&Eventlist: when one member picked up call from Ring Group, UCM didn’t send NOTIFY 

message to other members 

¶ Fixed BLF&Eventlist: cannot monitor remote parking lot when outbound pattern is prefixed with ‘0_’ 

¶ Fixed BLF&Eventlist: UCM will reply incorrect expire when subscribe updates in dialog  

¶ Fixed BLF&Eventlist: UCM will send notify to private IP address when NAT option is enabled 

¶ Fixed BLF&Eventlist: UCM will send second refresh subscribe to private IP address when NAT option 

is enabled 

¶ Fixed ZeroConfig: GXV3275 auto answer call-info preview error 

¶ Fixed ZeroConfig: GXV3240 template doesn’t show extension board settings 

¶ Fixed ZeroConfig: GXV3140 has error web access mode p value from UCM 

¶ Fixed ZeroConfig: GXP2140 device missing account 2 option in custom config page 

¶ Fixed ZeroConfig: GXP2135 template doesn’t include in model template list 

¶ Fixed ZeroConfig: GXP1610 XML template caused CGI crash 

¶ Fixed ZeroConfig: GXP1625 cannot auto pick extension from UCM 

¶ Fixed ZeroConfig: GXP1600 series cannot obtain LDAP phonebook XML file from UCM 

¶ Fixed ZeroConfig: GXP1628 upgrade method issue 

¶ Fixed ZeroConfig: GXP2200 fail to auto assign extension after deleting the original extension 

¶ Fixed ZeroConfig: GXP2200 preview and web access mode doesn’t match 

¶ Fixed ZeroConfig: GAC2500 cannot auto assign and pick up extension 

¶ Fixed ZeroConfig: DP715 NAT traversal doesn’t have UPNP option 

¶ Fixed ZeroConfig: GSWave cannot obtain correct p value for auto answer from UCM 

¶ Fixed ZeroConfig doesn’t display null when extension number is not set 

¶ Fixed ZeroConfig cannot auto discover in VLAN 

¶ Fixed ZeroConfig deleting device from zero config page will cause error prompt 

¶ Fixed ZeroConfig disabled template still shows as active in the template list 

¶ Fixed ZeroConfig global policy tooltips multi-language issue 

¶ Fixed ZeroConfig global policy doesn’t display XML phone book size 

¶ Fixed ZeroConfig global policy XML phone error prompt language display issue 

¶ Fixed ZeroConfig global policy set to manual cannot display related configuration options 

¶ Fixed ZeroConfig global policy allow to upload all file format as firmware 

¶ Fixed ZeroConfig global policy allow to upload all file format as XML phone book file 

¶ Fixed ZeroConfig global policy error prompt when deleting template 

¶ Fixed ZeroConfig global policy has incomplete tooltips 

¶ Fixed ZeroConfig cannot modify MPK and MPK EXT board settings 
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¶ Fixed ZeroConfig cannot redirect user to zero config page when zero config is disabled 

¶ Fixed ZeroConfig doesn’t support concurrent registration 

¶ Fixed ZeroConfig reboot the device on extension page caused crash 

¶ Fixed ZeroConfig doesn’t support concurrent registration 

¶ Fixed ZeroConfig will auto assign deleted extension to device 

¶ Fixed ZeroConfig cannot provision devices when UCM has class B IP address 

¶ Fixed ZeroConfig abnormal display when template name has special characters 

¶ Fixed ZeroConfig account preview doesn’t match config file 

¶ Fixed ZeroConfig: some IP will cause error prompt “unable to update your request” 

¶ Fixed ZeroConfig cannot set device IP in range of 172.16.0.255 and 172.16.1.0 

¶ Fixed ZeroConfig auto discover will fail if DHCP server has changed 

¶ Fixed ZeroConfig auto discover cannot display class B range IP address 

¶ Fixed ZeroConfig abnormal display when reset model template LDAP phone book to default 

¶ Fixed ZeroConfig vulnerability about HTTP header injection 

¶ Fixed ZeroConfig extension cannot display in device list 

¶ Fixed ZeroConfig auto discover issue  

¶ Fixed ZeroConfig pick up extension requires device to reboot when updating from model update page 

¶ Fixed Voicemail: Skip Voicemail Password Authentication is still active when voicemail is disabled 

¶ Fixed Voicemail: UCM sends email to member whose voicemail box is full 

¶ Fixed Voicemail: reply voice message to sender through peer trunk will fail 

¶ Fixed Voicemail: UCM will save voicemail for deleted extension 

¶ Fixed Voicemail: status doesn’t display extension voicemail after UCM reboots 

¶ Fixed Voicemail: email attachments invalidity issue 

¶ Fixed LDAP QR code doesn’t contain public IP address 

¶ Fixed LDAP cannot auto fill in extension last name when importing VCF format phonebook 

¶ Fixed LDAP mobile, home and fax number cannot contain character “-” 

¶ Fixed LDAP doesn’t stop sending request after timeout when LDAP sync fails 

¶ Fixed Backup doesn’t have complete CDR information 

¶ Fixed Backup cannot restore default extension music on hold after factory reset 

¶ Fixed Backup cannot display file list on USB  

¶ Fixed Backup cannot fully restore backup files 

¶ Fixed Backup: no error prompt when trying to download backup file when external media is 

unplugged 

¶ Fixed Backup: cannot restore MOH when restoring voice prompt files 

¶ Fixed Backup: deleted IVR still existed in the backup file causing callback issue 

¶ Fixed Backup: refreshing web UI during backup will cause UCM fails to reboot 

¶ Fixed IVR dial ‘0’ for operator voice prompt incorrect issue 

¶ Fixed IVR cannot record new prompt from extension issue 

¶ Fixed IVR time out and invalid destination CDR display incorrect issue 

¶ Fixed Conference: joining conference doesn’t hear voice prompt issue 

¶ Fixed Conference: muted member cannot be displayed on web UI 
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¶ Fixed Conference background noise not handled correctly issue 

¶ Fixed Conference no join tone after user is invited to conference room 

¶ Fixed Conference busy tone is too long when user rejects the invitation 

¶ Fixed Conference meeting time is not accurate issue 

¶ Fixed Conference invited member bridging local MCB will fail 

¶ Fixed Conference playing MOH music when invited member holds the conference 

¶ Fixed Conference MOH can be initiated from any joined users 

¶ Fixed Conference DTMF inband password doesn’t work for remote conference room 

¶ Fixed Conference admin privilege user can clean up conference schedule 

¶ Fixed Conference mute all option can mute other administrators in the same conference room 

¶ Fixed Conference doesn’t play hold music issue when single member in the conference room 

¶ Fixed Conference admin press ‘*’ doesn’t play correct prompt 

¶ Fixed Conference members who are invited from web UI into the conference room cannot use 

conference menu 

¶ Fixed Conference: incorrect first name in the email when receiving invitation at remote side for 

scheduled conference 

¶ Fixed Conference SIP subscription is not cleared when an invited user rejects the call 

¶ Fixed Conference choppy voice when both PCMU and G722 codec are used in conference room 

¶ Fixed Conference: recording is always activated even auto recording options is disabled 

¶ Fixed Conference: admin cannot hear voice prompt when entering conference room as first person 

¶ Fixed Conference: web UI doesn’t update status when members are mute / unmute by admin using 

*83 

¶ Fixed Conference: web UI doesn’t update status when admin lock / unlock conference room 

¶ Fixed Conference schedule can still add MCB when scheduled conference has reached maximum 

capacity 

¶ Fixed Conference scheduled cannot count invited members properly when they are not available 

¶ Fixed Conference schedule doesn’t sort the local extension 

¶ Fixed Conference schedule error prompt when scheduling conference time 

¶ Fixed Conference schedule email invitation has password when password is not required 

¶ Fixed Conference CCM: invited user cannot use CCM menu when “Enable User Invite” is enabled 

¶ Fixed Conference CCM: lock / unlock conference using CCM / web UI doesn’t play voice prompt 

¶ Fixed Conference CEI: GXP user fails to display conference info when more than 24 members are in 

the conference room 

¶ Fixed Conference CEI memory leak issue when members join the conference and subscribe CEI 

¶ Fixed Conference CEI notify doesn’t carry invite status when “Enable User Invite” is enabled 

¶ Fixed Conference CEI count error after MCB is created or kicked 

¶ Fixed Conference CEI MCB cannot display remote user 

¶ Fixed Conference CEI cannot show remote conference after MCB via SIP register trunk 

¶ Fixed Conference CEI doesn’t take effect when UCM restarts 

¶ Fixed Conference CEI doesn’t update mute / unmute status 
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¶ Fixed Conference CEI user subscription doesn’t clear up after being kicked out of the conference 

room 

¶ Fixed Conference CEI: customized caller ID will cause conference CEI display abnormal 

¶ Fixed Conference CEI: UCM will crash when user kicks MCB which has unsuccessful CEI re-

subscription 

¶ Fixed Conference CEI: UCM doesn’t send notify to member who is kicked by using feature code */8/2 

¶ Fixed Conference CEI: abnormal encode header in NOTIFY message when more than 19 members 

join local conference and subscribe CEI 

¶ Fixed Conference CEI: when more than 32 members join and leave conference with CEI enabled will 

cause UCM system crash 

¶ Fixed SLA will have miss call record when inbound call to SLA station 

¶ Fixed PBX Status display issue when ring group members are no longer available 

¶ Fixed PBX Status call queue member display issue 

¶ Fixed PBX Status CGI disconnect and abnormal display 

¶ Fixed PBX LDAP server web UI Spanish display issue  

¶ Fixed PBX office/holiday web page language prompt error 

¶ Fixed PBX FXS status display error 

¶ Fixed SPY Whisper mode abnormal behavior when trying to monitor idle extension 

¶ Fixed SPY plays error extension number when monitoring FXS extension 

¶ Fixed SPY: call barging display issue when monitoring external number 

¶ Fixed SPY: monitoring invalid extension doesn’t have error prompt 

¶ Fixed SPY: voice prompt is incorrect when using feature code to monitor FXS extension 

¶ Fixed SPY: monitored extension set to unconditional forward will cause web UI display two identical 

calls in active call page 

¶ Fixed Follow me: using feature code *80 / *81 to call follow me members will cause web UI display 

two identical calls in active call page 

¶ Fixed Follow me: voice prompt error when default destination is IVR 

¶ Fixed Troubleshooting capture filter can have special characters 

¶ Fixed voice prompt doesn’t match web UI language selection 

¶ Fixed WebRTC smart route enable destination option to gray 

¶ Fixed WebRTC: special characters in the TURN server password will cause prompt fail to update data 

¶ Fixed WebRTC: tooltips issue for “Max bandwidth” option in Chinese 

¶ Fixed Google service will stop working when restore backup file 

¶ Fixed Fax file name multi-language display issue 

¶ Fixed Paging Intercom tool tips typo 

¶ Fixed Paging Intercom feature code *81 doesn’t work issue 

¶ Fixed Paging Intercom cannot display caller ID name issue 

¶ Fixed Paging Intercom abnormal behavior after reset user data when Paging Intercom has 

customized prompt 

¶ Fixed Ring Group cannot modify extension number when ring group voice mail is enabled 

¶ Fixed Ring Group ring in order issue when there are remote members in the ring group 
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¶ Fixed Ring Group call will drop in 20 seconds when the call is transferred to extension’s voicemail 

¶ Fixed Upgrade: upgrade has a low chance will fail when upgrade to latest firmware 

¶ Fixed Fax / T.38 has incorrect tooltips 

¶ Fixed Fax / T.38 doesn’t work correctly on SIP trunk 

¶ Fixed System Event: alert contacts can apply same email address when change different web UI 

language 

¶ Fixed System Event: incorrect alert for “SIP Outgoing Call Through” prompt 

¶ Fixed System Event will generate SIP Lost Registration alert to unregistered extension 

¶ Fixed System Event doesn’t generate SIP fail warning when registration failed 

¶ Fixed System Event warning email notification can be enabled when email address is not set 

¶ Fixed System Event Disk Usage alert only detects data partition 

¶ Fixed System Crash caused by no SDP content in SIP INVITE header 

¶ Fixed System is vulnerable to XSS attack 

¶ Fixed System: DNS query caused system crash 

¶ Fixed DISA: call completion mode will cause user fail to use DISA 

¶ Fixed DISA call will enter voicemail when DISA call is being transferred and hung up 

¶ Fixed AMI: originating a call from AMI interface cannot leave a voicemail when callee rejects the call 

¶ Fixed Operation log: IVR key event language display abnormal 

¶ Fixed Operation log: super admin login to UCM doesn’t generate operation log 

¶ Fixed Operation log: some operations don’t have page detail in operation log 

¶ Fixed Operation log tooltips unclear issue 

¶ Fixed Operation log: IP address doesn’t have valid format restriction 

¶ Fixed Setup Wizard register trunk with cannot be saved with some specific settings 

¶ Fixed NAT: UCM IP NAT update issue 

¶ Fixed SIP option request is rejected with 403 response 

¶ Updated bundle of CA root certificates  

¶ Fixed E1/T1/J1: missing last digit when prepending prefix for trunk 

¶ Fixed E1/T1/J1: cannot apply different signaling method 

¶ Fixed E1/T1/J1: inbound call failed when DID pattern sets to “x./!”  

¶ Fixed E1/T1/J1: UCM will send out wrong caller ID when local and remote side has same extension 

¶ Fixed E1/T1/J1: UCM crash when calling into conference using E1 PRI signaling 

¶ Fixed E1/T1/J1: active call page will display incorrect caller ID when switching between PRI and EM 

 

NEW FEATURES OVERVIEW 

This section lists major new features and describes how to use it from the user’s point of view. 
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EXTENSION STATUS IMPROVEMENT  

The UCM6510 has new layout for extension status under web UI. Extensions will be automatically sorted based 

on their status: idle, ringing, talking or unavailable, and display them accordingly on the web UI status section.  

 

 

FEATURE CODE SELECTION IMPROVEMENT 

The UCM6510 now allows user to one click enable / disable specific feature code. To configure this feature, 

please navigate to web UI-> PBX->Internal Options->Feature Codes->Feature Codes.  

 

By default, all the feature codes are enabled. Unchecking the box will disable the feature code. 

 

URUGUAY TIME ZONE SUPPORT 

Uruguay time zone with day light saving is now supported on the UCM6510. This feature can be found under 

web UI-> Settings->Time Settings->Auto Time Updating->Time Zone from the time zone list. 
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DISTINGCTIVE RING TONE SUPPORT 

The UCM6510 now supports to have distinctive ring tone when an inbound call is coming from call queue / IVR / 

inbound route / extension. Users can configure the “alert-info” filed to select different ring tone for a specific 

incoming call.  

1. Call Queue configuration, please navigate to web UI->PBX->Call Features->Call Queue->Create New 

Queue/Edit Queue->Queue Options->Alert-Info. 
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2. IVR configuration, please navigate to UI->PBX->Call Features->IVR->Create New IVR/Edit IVR->Alert-

Info. 
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3. Inbound route configuration, please navigate to web UI->PBX->Basic / Call Routes->Inbound Routes-> 

Create New Inbound Routes/Edit Inbound Routes->Alert-Info. 

 

4. Extension configuration, please navigate to web UI->PBX->Basic / Call Routes->Extension->Create / Edit 

Extension->Media to configure Alert-info.  
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SFTP CLIENT ACCOUNT SPECIAL CHARACTRE SUPPORT 

The UCM6510 now supports special characters for SFTP client account, such as @ or ‘.’. This change allows 

user to use email address as SFTP accounts. To configure this feature, please navigate to web UI-> 

Maintenance->Backup->Data Sync->Account. 

 

 

DESTINATION DIRECTORY 

The UCM6510 now allows users to specify the destination directory on SFTP server for backup file. If the 

directory doesn’t exist on the destination, UCM6510 will create the directory automatically. To configure this 

feature, please navigate to web UI->Settings->Recordings Storage->Recordings Storage. Users could choose 

USB, SD card or Local disk as destination.  
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RING GROUP MUSIC ON HOLD 

The UCM6510 now supports music on hold for ring group. Users can upload custom prompt for specific ring 

group. Please navigate to web UI->PBX->Call Features->Ring Group->Create New Ring Group/Edit, from the 

drop down menu, select the hold music from music on hold class to play for the ring group. 

 

 

CDR MULTI EMAIL AND SPECIFIC TIME DOWNLOAD SUPPORT 

The UCM6510 now supports CDR multiple email recipients and ability to configure specific hour to receive the 

CDR record. To have more than one email recipients, please separate each email address by semi-colon. If 

hour field is configured, UCM6510 will send out CDR at specified time. To configure this option, please navigate 

to web UI->Status->CDR->CDR->Automatic Download Settings. 
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BLACKLIST ANONYMOUS CALL BLOCK  

The UCM6510 supports users to add “Anonymous” caller to Blacklist to block calls which do not have caller ID 

and caller ID name. To configure this feature, please navigate to web UI->PBX->Basic->Inbound Routers-> 

Blacklist->Add Blacklist Number. Users should type in “Anonymous” to enable this feature. 

 

 

EVENTLIST: SORTING SELECTED EXTENSION  

The UCM6510 now supports sorting selected extension manually in eventlist. Users can now arrange the order 

of selected extensions. This feature can be found under web UI-> PBX-> Call Features-> Eventlist.  
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WEB UI LOGIN IMPROVMENT  

The UCM6510 now adds login retry limits to prevent brutal force decryption. Users can configure maximum 

failed login attempts, once the limit is reached, the IP address will be banned for a period of time based on 

user’s configuration. In addition, user can also add specific IP address to the white list to avoid restrictions. This 

feature can be found under web UI->Settings->Login Settings->Login Settings.  
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EMAIL TEMPLATE  

The UCM6510 now supports email template for email notifications. Users can modify templates to be used in 

appropriate scenarios. This feature can be found under web UI->Settings->Email Settings->Email Templates.  

 

To configure an email template, simply click the  button under Options column, and edit the template as 

desired.  
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OUTBOUND ROUTE: COUNTRY RESTRICTION 

The UCM6510 now allows users to put country code restrictions on specific outbound routes. Once the 

restriction is enabled, call to the restricted country cannot be placed on that specific trunk. To configure this 

feature, please navigate to web UI->PBX->Basic->Outbound Routes->Country Codes.  

 

 

EXTERNAL DISK USAGE ALERT 

The UCM6510 now can send alert for external disk usage. If this alert is turned on, once external disk, such as 

USB / SD card, reaches the predetermined threshold, UCM6510 will send notification to email recipient. This 

feature can be found under web UI->Status->System Event List->External Disk Usage. 
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DYNAMIC DEFENSE: WHITE LIST RANGE IP SUPPORT 

The UCM6510 now supports white list to filter range of IP and ports. Users can determine range of IP in the 

white list instead of keying in IP one by one. This feature can be found under web UI->Settings->Firewall-> 

Dynamic Defense->Dynamic Defense. 

 

 

FAIL2BAN: BLACKLIST 

The UCM6510 now supports fail2ban blacklist, users will be able to view the IPs that have been blocked by 

UCM6510. This feature can be found under web UI->Settings->Fail2Ban->Blacklist. 
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ZERO CONFIG: REBOOT DEVICE 

The UCM6510 now supports rebooting discovered device from zero config page. To use this feature, please 

navigate to web UI->PBX->Zero Config->Zero Config, by clicking the reboot button under Options tab.  

 

 

ZERO CONFIG: GXP1628B SUPPORT 

The UCM6510 now has GXP1628B model available for zero config.  

 

1. To config this model, please first download it from web UI-> PBX-> Zero Config-> Model Update-> 

Model Template Package List-> GXP1628B. 
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2. After installing GXP1628B model template, Please navigate to Model Templates page to configure 

GXP1628B template as desired. 

 

 

PIN GROUP SUPPORT 

The UCM6510 now supports pin group. Once pin group is configured, users can apply pin group to specific 

outbound routes. When placing a call on pin protected outbound routes, caller will be asked to input the group 

pin number.  
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Please note, if pin group is enabled on outbound route level, password, privilege level and enable filter on 

source caller ID will be disabled.  

 

 

If pin group CDR is enabled, the call with pin group information will be displayed as part of CDR under Account 

Code field.  
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H-MOBILE PMS SUPPORT 

The UCM6510 now supports PMS hotel features for H-Mobile. By accessing the PMS feature, users will be able 

to handle / update hotel room requests, such as room check in / out, wake up call, room service request etc. To 

configure PMS settings, please navigate to web UI->PBX->PMS.  

 

CALL QUEUE: CUSTOM PROMPT 

The UCM6510 supports custom prompt feature in call queue. This custom prompt will active after the 

caller waits for a period of time in the Queue. Then caller could choose to leave a message/ transfer to 

default extension or keep waiting in the queue.   

 

To configure this feature, please go to UCM web UI->PBX->Call Features->Call Queue->Create New 

Queue/Edit Queue->Queue Options->set Enable Destination to Enter Destination with Voice Prompt. 

Users could configure the wait time with Voice Prompt Cycle.  
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CALL QUEUE RETRY TIME 

Users now can change retry time in call queue. Retry time will determine the time for a call in the call queue to 

wait before ringing the next agent. This feature can be found under web UI->PBX->Call Features->Call Queue, 

click on create / edit to modify the retry time value.  

 

 

ADDED ENHANCEMENT FOR ANONYMOUS CALLS ON SIP TRUNK 

The UCM6510 now supports to add SIP Trunk INVITE “privacy=full” on RPID header when Anonymous call to 

an external number from a detected extension. 

!$$%$ +%%0 4(% Ȱ#!,,-).&/ȱ 3)0 (%!$%2 &2/- '80 0(/.% 53).' 0!').' -/$% 

The UCM6510 supports GXP Phone with Paging Mode instead of dialing *81. When GXP phone using 

paging mode to dial, user doesn’t need to dial feature code *81 for paging mode to take effect. 
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FIRMWARE VERSION 1.0.10.44 

 

PRODUCT NAME 

UCM6510 

DATE 

04/22/2016 

IMPORTANT UPGRADING NOTE 

¶ For UCM6510 that’s already on 1.0.10.39 / 1.0.10.42, please upgrade to 1.0.10.44 directly using 

“ucm6510fw.bin” file. Backup your data (including configuration) before upgrading is highly 

recommended. 

 

¶ For UCM6510 that’s still on 1.0.2.7 (or lower), please follow upgrading instructions to upgrade 

to 1.0.10.44. 

 

¶ Backup, Backup, Backup, yes, backup your data (including configuration) before doing any 

firmware upgrade!  (An SD card or USB Flash Drive is needed for backup purpose.) 

 

¶ For UCM6510, upgrading from firmware version 1.0.2.7 (or lower) to firmware version 1.0.10.44 

directly is not supported. Please upgrade to 1.0.2.97 (in the firmware package) first, before 

upgrading to 1.0.10.44. The firmware upgrading process should be 1.0.2.7 (or lower) -> 1.0.2.97 

-> 1.0.10.44. 

 

¶ The UCM6510 will be reset to factory default settings after upgrading to 1.0.10.44.  Users need 

restore backup file manually or re-configure after upgrade.  Therefore, it is VERY IMPORTANT 

to manually BACKUP data on the UCM6510 before upgrade.  Users will also be requested for 

backup when upgrading from 1.0.2.97 to 1.0.10.44. 

 

¶ Once upgraded to 1.0.10.44, downgrading to 1.0.2.7 (or lower) is not supported. 

 

 

CHANGES SINCE FIRMWARE VERSION 1.0.10.42 

ENHANCEMENT 

¶ Added  Zero Config DP750 support 
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¶ Added Configure framing with 'esf' or 'd4' in T1/J1 (6510) 

 

BUG FIX 

¶ Fixed PJSIP pool caused crashing issue 

¶ Fixed CDR auto download by month CSV file empty issue 

¶ Fixed CDR API Sub_CDR_1 field is duplicate on JSON file 

 

NEW FEATURES OVERVIEW 

This section lists major new features and describes how to use it from the user’s point of view. 

ZERO CONFIG DP750 SUPPORT 

The UCM6510 now supports DP750 model template on Zero Config page. 

1. Please navigate to web UI-> PBX-> Zero Config-> Model Update page to download DP750 model 

template. 

 

 

2. After installed DP750 model template, Please navigate to Model Templates page to configure DP750 

template as desired. 
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The UCM6510 now added framing option with 'esf' or 'd4' in T1/J1 digital trunk 

This option can be found under web UI-> PBX-> Ports Config-> Digital Hardware-> Edit Digital Ports-> 

Basic Settings  
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FIRMWARE VERSION 1.0.10.42 

PRODUCT NAME 

UCM6510 

DATE 

03/28/2016 

IMPORTANT UPGRADING NOTE 

¶ Backup, Backup, Backup, yes, backup your data (including configuration) before doing any 

firmware upgrade!  (An SD card or USB Flash Drive is needed for backup purpose.) 

 

¶ For UCM6510, upgrading from firmware version 1.0.2.7 (or lower) to firmware version 1.0.10.42 

directly is not supported. Please upgrade to 1.0.2.97 (in the firmware package) first, before 

upgrading to 1.0.10.42. The firmware upgrading process should be 1.0.2.7 (or lower) -> 1.0.2.97 

-> 1.0.10.42. 

 

¶ The UCM6510 will be reset to factory default settings after upgrading to 1.0.10.42.  Users need 

restore backup file manually or re-configure after upgrade.  Therefore, it is VERY IMPORTANT 

to manually BACKUP data on the UCM6510 before upgrade.  Users will also be requested for 

backup when upgrading from 1.0.2.97 to 1.0.10.42. 

 

¶ Once upgraded to 1.0.10.42, downgrading to 1.0.2.7 (or lower) is not supported. 

 

CHANGES SINCE FIRMWARE VERSION 1.0.10.39 

BUG FIX 

¶ Fixed Register Trunk “From domain” configuration causes register message has route header 

¶ Fixed Register Trunk “From domain” configuration causes trunk status display issue 

¶ Fixed Trunk outbound CID not carried issue 
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FIRMWARE VERSION 1.0.10.39 

PRODUCT NAME 

UCM6510 

DATE 

02/03/2016 

IMPORTANT UPGRADING NOTE 

¶ Backup, Backup, Backup, yes, backup your data (including configuration) before 

doing any firmware upgrade!  (An SD card or USB Flash Drive is needed for backup 

purpose.) 

 

¶ For UCM6510, upgrading from firmware version 1.0.2.7 (or lower) to firmware version 1.0.10.39 

directly is not supported. Please upgrade to 1.0.2.97 (in the firmware package) first, before 

upgrading to 1.0.10.39. The firmware upgrading process should be 1.0.2.7 (or lower) -> 1.0.2.97 

-> 1.0.10.39. 

 

¶ The UCM6510 will be reset to factory default settings after upgrading to 1.0.10.39.  Users need 

restore backup file manually or re-configure after upgrade.  Therefore, it is VERY IMPORTANT 

to manually BACKUP data on the UCM6510 before upgrade.  Users will also be requested for 

backup when upgrading from 1.0.2.97 to 1.0.10.39. 

 

¶ Once upgraded to 1.0.10.39, downgrading to any previous version is not supported. 

UPGRADING INSTRUCTIONS 

Following are the upgrade steps from 1.0.2.7 to 1.0.10.39. 

 

11. Upgrade UCM6510 from firmware 1.0.2.7 to 1.0.2.97 using the 1.0.2.97 “ucm6500fw.bin” file. 

12. When the UCM6510 is on firmware 1.0.2.97, open a web browser on a PC connected to the same 

network as UCM6510 to log in UCM6510 web UI. Go to Maintenance->Upgrade page, manually 

upload “ucm6500dpt.bin” file under “Local Upgrade” section from your PC.  

13. Once the UCM6510 finishes loading the ucm6500dpt.bin file successfully, it will reboot and 

automatically boot into recovery mode. 

14. In recovery mode, the UCM6510 LCD will display its IP address. Please type this IP address in the 

web browser of your PC that is connected to the same network as the UCM6510. Please make sure 

you have cleared your browser cache and then type in IP address only (Do not specify protocol or 
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port number). For example, if the IP address displayed in LCD is 192.168.1.2, please type in 

192.168.1.2 in the browser address bar. 

15. The following figure shows the UCM6510 web UI in recovery mode. Log in the UCM6510 as 

administrator. 

 

 

16. Once logged in (as shown in figure below), click on “Upload” and select firmware 1.0.10.39 

“ucm6500fw.bin” file from your PC to upload. 

 
 

17. Please keep the web page open and wait until uploading is finished. Once done, an upgrading 

successful message will be prompted. 

 

 

18. On the recovery mode web UI, select “Reboot” to reboot the UCM6510. 
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19. Your UCM6510 is successfully upgraded to 1.0.10.39. 

 

CHANGES SINCE FIRMWARE VERSION 1.0.2.7 

ENHANCEMENT 

¶ Upgrade Asterisk version to Asterisk 13.4.0 

¶ Added support for concurrent registration so that multiple devices can register to UCM6510 using the 

same extension 

¶ Added SIP Message support for SIP end devices to send and receive messages to each other 

¶ Added 100rel support for SIP Provisional Message Reliability, which enables reliability to SIP 

provisional response. The option is under web UI->PBX->SIP settings->TOS. 

¶ Added video preview support 

¶ Added SIP Update support for session timer 

¶ Added SIP presence support to subscribe for status information  

¶ Inbound Route 

o Added multiple mode support for inbound route to allows users to switch between 

destinations conveniently 

o Added prepending prefix for inbound route 

¶ Fax 

o Added Fax sending support in web UI User Portal page 

o Added Fax intelligent routing support so that UCM can automatically detect and forward Fax 

or phone signal coming from FXO port to the proper destination 

o Added Re-Invite with two media (audio, image) support for fax sending. If Fax re-invite 

contains both T.38 and PCMA/PCMU codec, UCM650 will select T.38 codec over 

PCMA/PCMU. Fax process will not be interrupted 

¶ Added conference schedule support for users to reserve conference room on the UCM 

¶ Added Google Service Settings support to sync UCM6510 conference schedule with Google 

Calendar 

¶ Added Setup Wizard 

¶ Added Zero Config Model Template for GXP110x 

¶ Added Zero Config Model Template for GXP2170 

¶ Added ability to customize specific prompt 

¶ Added FXS Off-hook Auto Dial feature 

¶ Added option “ALL” when making backup file 

¶ Added option “Use IP Address in SDP” in web UI->PBX->SIP Settings->NAT 

¶ Added IVR dialing options for internal extensions 

¶ Improved CDR to show more information such as transferred call 

¶ Added default destination option in Follow Me feature 

¶ Added WebUI Turkish language support 
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BUG FIX 

¶ Fixed Follow Me Numbers ring timeout doesn’t have highest priority 

¶ Fixed Follow Me doesn’t call next number immediately if the first number is disabled 

¶ Fixed Follow Me doesn’t play “call-from” prompt before caller name 

¶ Fixed Follow Me Number’s ring timeout doesn’t have highest priority 

¶ Fixed IVR call back loop issue 

¶ Fixed IVR personal language setting cannot override global language setting when playing prompt 

¶ Fixed IVR prompt link issue for “Timeout Prompt” and “Invalid Prompt” 

¶ Fixed IVR key pressing event abnormal behavior when call service doesn’t exist 

¶ Fixed Outbound Rule can strip more characters than the pattern length 

¶ Fixed Outbound and Inbound Rule cannot save more than one “_” in the pattern 

¶ Fixed Outbound Rule pattern input issue 

¶ Fixed Outbound Rule input character restriction 

¶ Fixed Outbound Rule cannot automatically add “_” character 

¶ Fixed Outbound Route “Custom Dynamic Route” cannot save after maximum character length 

without “_” 

¶ Fixed Inbound Routes doesn’t show time and type 

¶ Fixed Inbound Rule cannot add more than two time conditions 

¶ Fixed Inbound Routes DID destination appears when DID is not selected 

¶ Fixed ZeroConfig: some customize configuration settings restore to default value after upgrade 

¶ Fixed ZeroConfig: when phonebook directory is set to manual, refreshing page is abnormal 

¶ Fixed ZeroConfig: upload wallpaper issue 

¶ Fixed ZeroConfig: UCM sends time zone with wrong P value 

¶ Fixed ZeroConfig: GXP1610 template does not match web Interface 

¶ Fixed ZeroConfig: GXP1625 phonebook key function options are incomplete 

¶ Fixed ZeroConfig: GXP16xx model lack of picture 

¶ Fixed ZeroConfig: GXP16xx idle screen XML always displays "disabled" in preview 

¶ Fixed ZeroConfig: GXP2140 customize setting is missing account 2 configuration 

¶ Fixed ZeroConfig: GXP2140 preview displays error when language is set to Svenska in global policy 

¶ Fixed ZeroConfig: device version number can fill in with illegal character 

¶ Fixed ZeroConfig: upload incorrect pack model file will cause system no response 

¶ Fixed ZeroConfig: some models display incomplete 

¶ Fixed ZeroConfig: system no response issue when uploading empty Phonebook XML file 

¶ Fixed ZeroConfig: a message prompts in phonebook storage when uploading a file contains “()” 

character  

¶ Fixed ZeroConfig: new file name with long length causes abnormal behavior 

¶ Fixed ZeroConfig: UCM sends language with wrong P value to gateway 

¶ Fixed ZeroConfig: model update will fail to load if UCM is placed in private network 

¶ Fixed ZeroConfig: GXV32xx MPK P-value is incorrect 

¶ Fixed ZeroConfig: device cannot provision end point if dial plan contains < or > characters 

¶ Fixed ZeroConfig: the preview and P value do not match for GXP2200 



 

GRANDSTREAM NETWORKS                      UCM6510 RELEASE NOTE                                                                PAGE 94 

¶ Fixed ZeroConfig: Handset 2 or 3 settings are not carried in the generated config file after configuring 

DP715 Handset 2 and 3 in customize device settings 

¶ Fixed Video codec negotiation error when call is put on hold 

¶ Fixed Call cannot be parked twice 

¶ Fixed Call disconnects after being parked and not picked up 

¶ Fixed Cannot transfer a parked call from pickup extension using transfer feature codes 

¶ Fixed Video codec negotiation issue when making outgoing call 

¶ Fixed Outgoing call password causes no ring back tone 

¶ Fixed Basic Call: Blind transfer caller name display issue 

¶ Fixed “Call Forward No Answer” cannot call external number when “Filter on Source Caller” is 

enabled  

¶ Fixed Call Recording stopped after call is parked 

¶ Fixed FXS: Three-way calling can hear MOH when no one is on hold 

¶ Fixed FXS: extension flashing issue before callee picks up 

¶ Fixed FXS: calling extension doesn’t have ring back tone 

¶ Fixed FXS: can hear echo before the call is picked up 

¶ Fixed FXS: extension returns to three-way calling directly after it puts the call on hold 

¶ Fixed FXS: Call Forward Unconditional doesn’t take effect 

¶ Fixed FXO: failed to detect callerID when FXS sends callerID 

¶ Fixed FXO: frequency range in tooltip is not accurate 

¶ Fixed FXO: CID detection failure issue 

¶ Fixed Firewall: IP and Port restriction doesn’t take effect 

¶ Fixed Firewall: cannot restrict network level access 

¶ Fixed Firewall: error prompt display issue for incorrect IP address 

¶ Fixed Firewall: reject rules causes RTP stream being blocked  

¶ Fixed Firewall: cannot modify reject rules in Static Defense 

¶ Fixed LDAP client cannot query a single phonebook from the LDAP server 

¶ Fixed LDAP configuration has no error prompt 

¶ Fixed LDAP page keep loading when static defense is enabled 

¶ Fixed LDAP synchronization issue when using LDAP Outbound Rule 

¶ Fixed LDAP phonebook with Chinese call ID issue 

¶ Fixed LDAP synchronization script will kill other progress issue 

¶ Fixed RingGroup: call with custom prompt doesn’t have ring back tone 

¶ Fixed RingGroup: permission doesn’t apply to LDAP and external number 

¶ Fixed MOH: cannot delete all MOH default class 

¶ Fixed MOH: deleting customer prompt cannot restore default prompt 

¶ Fixed MOH: modification failure in call queue because of reset/reboot 

¶ Fixed Backup: UCM cannot restore voice prompt package after factory reset 

¶ Fixed Backup: cannot backup “Login Timeout Settings”  

¶ Fixed Backup: when SD card is missing, prompt message is incorrect 

¶ Fixed Backup: recording file time attribute display issue 
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¶ Fixed Backup: using config files cannot backup Music On Hold class 

¶ Fixed Custom Prompt with special character in the file name will fail to upload 

¶ Fixed Extension “ring simultaneously” can't take effect when “Skip Trunk Auth” set to “By time” 

¶ Fixed Extension concurrent users batch import CSV file issue 

¶ Fixed Extension caller ID shows as <unknown> when member's name has character ‘(’ or ‘)’ 

¶ Fixed When switching between different languages, extension displays incorrectly 

¶ Fixed Cannot send Caller ID in Chinese to user via email 

¶ Fixed Extension caller ID importing issue 

¶ Fixed “Dial Trunk Password” can be the same as extension number when strong password is enabled 

¶ Fixed Extension is automatically dropped without warning when importing more extensions than the 

maximum allowed numbers 

¶ Fixed Extension prompt issue when import table doesn’t exist  

¶ Fixed When import extension fails, it still displays extension import successfully 

¶ Fixed Extension fails to register after UCM reboots 

¶ Fixed Extension prompt message error when CCBS request is through trunk and CCNR is full 

¶ Fixed Extension QR code display issue 

¶ Fixed “Email to User” can't automatically generate authenticate ID 

¶ Fixed Importing duplicate extensions will cause one-key dial fail to save 

¶ Fixed Extension registration process not handled correctly 

¶ Fixed CDR: when changing HTTP server, web API has no response 

¶ Fixed CDR API: last data field in CSV file is protected by double quotations 

¶ Fixed CDR synchronization issue through analog trunk  

¶ Fixed User Login with weak password cannot redirect user to reset password page 

¶ Fixed User Login with weak password has incorrect prompt when strong password is disabled 

¶ Fixed User Login language button disappear issue 

¶ Fixed Fax: VFax cannot find end user via analog trunk when Follow Me is enabled  

¶ Fixed Fax: super administrator cannot see administrator fax record 

¶ Fixed Fax: cannot delete multiple fax records in web UI fax sending page 

¶ Fixed Fax: language display and tooltip issues   

¶ Fixed Fax VFax extension will effect view of Fax files 

¶ Fixed Conference caller ID display abnormal when inviting users via trunk from web UI 

¶ Fixed SIP Setting: TCP mode IP header of SIP message doesn't contain "ToS for SIP" 

¶ Fixed SIP Setting: error prompt message for “Max bit rate” is inaccurate 

¶ Fixed Queue: agent can be deleted when queue still has active agent 

¶ Fixed Queue: blind transfer agent will hear “this call may be recorded” prompt 

¶ Fixed Queue: status displays incorrectly when extension name has Chinese character 

¶ Fixed Eventlist: Asterisk crash when deleting an event list 

¶ Fixed Eventlist: group extension doesn’t display extension name 

¶ Fixed Trunk: UCM sends Register message without the value of From user 

¶ Fixed Trunk: restrict special character @ to be used in username for Register trunk 
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¶ Fixed Trunk: DNS SRV doesn’t query the second sub-domain when first sub-domain returns no such 

name  

¶ Fixed Trunk: UCM sends unregistered request with wrong port In the SRV query when register trunk 

is disabled 

¶ Fixed When deleting Inbound/Outbound routes, warning message prompts 

¶ Fixed Analog trunk “Ring Detection Timeout” issue 

¶ Fixed New peer trunk doesn’t have caller ID and configuration 

¶ Fixed System Event: alert log shows "syntaxError" 

¶ Fixed System Event: editing alert requires user to click “apply changes” to take effect 

¶ Fixed System Event: alert event list abnormal behavior  

¶ Fixed System Event: Email notification and alert issue 

¶ Fixed System Status: clicking on “Network” multiple times will cause “abnormal system error” prompt 

¶ Fixed System Status: storage usage display issue 

¶ Fixed TCP/TLS error prompt issue 

¶ Fixed TCP/TLS: it allows to set web port as TCP port 

¶ Fixed SLA: prompt message when ring timeout/delay is set to 300 seconds 

¶ Fixed SLA: abnormal behavior when no SIP extension is available to match 

¶ Fixed SLA: abnormal behavior when no SLA trunk is available to select 

¶ Fixed User Management: consumer login cannot play and download auto recording files 

¶ Fixed User Management: deleting operation logs causes incorrect error prompt 

¶ Fixed User Management: changing administrator credential doesn’t require old password 

¶ Fixed Feature Codes: “reset all” cannot take effect 

¶ Fixed DDNS abnormal behavior when saving username and password as Chinese 

¶ Fixed Operation Log prompts when using wrong login credential to access UCM 

¶ Fixed Network LAN 1 with 802.1q on dual mode will lead to LAN unavailable on route mode 

¶ Fixed Even if the callee doesn’t have permission, the call is still transferred  

¶ Fixed New Zealand time zone error 

¶ Fixed Session timer: UCM cannot disconnect the callee when transport method is TCP 

¶ Fixed Dial By Name menu prompt issue 

¶ Fixed TLS CA Cert file in .exe format can still be uploaded 

¶ Fixed MCB unsuccessful CEI re-subscription caused Asterisk crashing issue 

¶ Fixed some language prompt, language translation and display issues 

¶ Fixed E1/T1/J1 digital trunk all circuits are busy issue caused by T310 timer   

¶ Fixed E1/T1/J1 prompt is not correct when switching from E1 to T1/J1 EM 

¶ Fixed E1/T1/J1 digital channels Status display incompletely when Signaling is SS7 or PRI 

¶ Fixed E1/T1/J1 UCM can't carry the correct calling number information when don't match all prefixes 

when set the "Calling Nature of Address Indicator” as Dynamic 

¶ Fixed E1/T1/J1 SS7&R2 unplug the E1 line during the ss7/R2 call UCM cannot release the call 
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NEW FEATURES OVERVIEW 

This section lists major new features and describes how to use it from the user’s point of view. 

SETUP WIZARD 

The UCM6510 provides setup wizard for users to configure basic settings after logging the UCM6510 web 

UI. Click on the “Setup Wizard” option on the upper right of the web UI and then follow the instructions 

step by step. 

 

 

The settings in setup wizard include change password, network settings, time zone, extensions, trunks 

and routes. The users can quit the setup wizard at any step and manually configure the UCM6510 

instead. A summary will be provided at the end of the wizard before applying the changes. 

 

 

CONCURRENT REGISTRATIONS PER EXTENSION 

Multiple SIP end devices can register on UCM6510 using the same extension account at the same 

time. This feature is turned off by default. 

 

To enable concurrent registrations for the extension: 

 

3. Log in UCM6510 web UI, go to PBX->Basic/Call Routes->Extensions, and select the extension to be 

used. 



 

GRANDSTREAM NETWORKS                      UCM6510 RELEASE NOTE                                                                PAGE 98 

4. Under Basic Settings tab->User Settings, for option “Concurrent Registrations”, configure the number 

of devices that will register using this extension. 

5. Save the setting and apply the change. 

 

SEND AND RECEIVE SIP MESSAGE 

SIP end devices that support SIP message can send and receive SIP messages using UCM6510 as the 

PBX. The following figure shows GXV3240/GXV3275 registered to UCM6510 are sending and receiving 

SIP messages to each other using the UCM6510 extensions. 

 

 

FAX SENDING SUPPORT IN WEB UI USER PORTAL PAGE 

The users can log in UCM6510 user portal using the extension to send Fax via UCM6510. To do this: 

1. Obtain the extension number and user portal password from UCM6510 administrator. Log in the 

UCM6510 user portal web UI using the extension login information. 

2. Go to User Portal->Value-added Features->Fax Sending. 

3. Enter the external Fax number and upload the Fax file. Click “Send”. 
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4. The Fax sending progress will be displayed. The users can also enter external Fax number to search 

for particular Fax sending status. 

 

CONFERENCE SCHEDULE SUPPORT 

The users can log in UCM6510 and schedule conference ahead of meeting time. Once scheduled, the 

extensions added into the conference schedule will receive call from UCM6510 at the scheduled time. To 

configure conference schedule, log in UCM6510 web UI and go to PBX->Call Features->Conference 

Schedule. Select “Create new Conference Schedule”, select conference room extension, configure 

theme, date, members and etc to reserve the conference room for conference schedule. 



 

GRANDSTREAM NETWORKS                      UCM6510 RELEASE NOTE                                                                PAGE 100 

 

GOOGLE SERVICE SETTINGS SUPPORT 

After configuring conference schedule, if the users would like to have the scheduled conference displayed 

in Google Calendar, the users must complete Google service settings on the UCM6510 using Google 

OAuth 2.0. Log in UCM6510 web UI and go to Settings->Google Service Settings->Google Service 

Settings to set it up. 
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INBOUND ROUTE MULTIPLE MODE 

For each inbound route on the UCM6510, “Default Mode” and “Mode 1” are available for the users to 

configure different inbound route destinations. The users can then dial feature code from their UCM6510 

extensions to switch between the two destinations defined in “Default Mode” and “Mode 1”. This feature is 

turned off by default and is usually used for small businesses to adapt to their flexible inbound route 

schedules. To avoid any misconfigurations, for UCM6510 in large scale deployment with multiple inbound 

routes for multiple trunks, strict office hour or formal time conditions and etc, it is not recommended to 

enable this feature. 

 

To use this feature: 

1. Log in UCM6510 web UI and go to PBX->Basic/Call Routes->Inbound Routes. Select the inbound 

route to be edited. 

2. Click on option “Inbound Multiple Mode” to enable it. Then select each tab and configure destinations 

for “Default Mode” and “Mode 1”. 
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3. The feature code to switch inbound route mode can be found under UCM6510 web UI->PBX-

>Internal Options->Feature Codes. Once enabled and configured, the UCM6510 extensions can dial 

the feature code to switch to “Default Mode” or “Mode 1”. Inbound multiple mode feature code is 

disabled by default. 
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PREPENDING PREFIX FOR INBOUND ROUTE 

For the inbound route on the UCM6510, if the default destination is set to “By DID”, the users could 

configure prepending digits for the destination. This option can be accessed under UCM6510 web UI-

>PBX->Basic/Call Routes->Inbound Routes. 

 

For example, if the incoming call’s DID is 18005251163 from the trunk via this inbound route, assuming 

“Strip” is set to “8” which means UCM6510 will strip the first 8 digits, and “Prepend” is set to “2” which 

means the UCM6510 will then prepend a “2” to the stripped number, the UCM6510 will now route the 

inbound call to extension “2163”.  

100REL SUPPORT 

The UCM6510 supports SIP Provisional Message Reliability, which enables reliability to SIP provisional 

response. To enable this feature, log in UCM6510 web UI, go to PBX->SIP Settings->ToS and select 

“Yes” for option “100rel”. 
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VIDEO PREVIEW SUPPORT 

If both SIP end devices registered to UCM6510 support video call and they have established an audio 

call, one party can initiate video request during the call, and it’s up to the remote side to decide whether to 

accept the video invitation or not.  

 

 

GXP2170/GXP110X MODELS ADDED IN ZERO CONFIG MODEL TEMPLATE 

Under UCM6510 web UI->PBX->Zero Config->Zero Config->Model Update, users can now download 

GXP2170 and GXP110x package as model template and use it for device provisioning. 
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Once downloaded, users can select it from the model list under UCM6510 web UI->PBX->Zero Config-

>Zero Config->Create New Device->option “Model”. 
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SPECIFIC VOICE PROMPT CUSTOMIZATION 

If the users would like to customize certain language prompt on the UCM6510, users could upload the 

voice prompt package with that specific prompt included in it, instead of uploading the whole package. For 

example, assuming the user has downloaded French voice prompt package and selected French as the 

system voice prompt language. Now the user would like to change the prompt “welcome.gsm” for French. 

To do this: 

1. Record the customized language voice prompt file “welcome.gsm” in French. 

2. Create a folder “fr” that has the “welcome.gsm” file in it. 

3. Create info.txt file that has the language name in it in below format: 

 

 

4. Zip the folder “fr” and “info.txt” files into a zip folder “fr.zip”, as below: 

 

 

5. Under “Choose Voice Prompt to Upload”, select “fr.zip” from PC and upload it. 

 

6. Save the setting and apply the change. 



 

GRANDSTREAM NETWORKS                      UCM6510 RELEASE NOTE                                                                PAGE 107 

FXS OFF-HOOK AUTO DIAL 

On the UCM6510, the users can have the FXS extension automatically dial a pre-configured number 

when the FXS station is off-hook.  

 

To use this feature: 

1. Log in UCM6510 web UI, go to web UI->PBX->Basic/Call Routes->Extensions, create or edit FXS 

extension. 

2. Under “Features” tab->Hotline, select the checkbox for “Enable Hotline” and configure the hotline 

number. 

3. Select “Hotline Type”. Two options are available: 

o Immediate Hotline: The hotline number will be dialed immediately when the phone is off-hook 

o Delay Hotline: The hotline number will be dialed in 5 seconds after the phone is off-hook 

 

DEFAULT DESTINATION IN FOLLOW ME 

Under UCM6510 web UI->PBX->Follow Me->Create New Follow Me, the users can enable destination 

and configure the default destination. If no one in the Follow Me answers the call, the call will be routed to 

this destination. 

 

3%,%#4).' Ȱ!,,ȱ 490%3 &/2 &),% "!#+50 

When creating a backup file for the UCM6510 under web UI->Maintenance->Backup->Backup/Restore-> 

Create New Backup->option “Choose Backup Files”, the users can select “All” to backup all typeS of 

backup files, instead of selecting each type one by one. 
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Under UCM6510 web UI->PBX->Call Features->IVR, users can select the extensions in specific 

categories such as extensions, conference, call queue, ring group and etc, to be reached via this IVR.  

 

USE IP ADDRESS IN SDP 

A new option “Use IP Address in SDP” is added under UCM6510 web UI->PBX->SIP Settings->NAT. If 

enabled, the SDP connection will use the IP address resolved from the external host. 
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MORE DETAILED CDR DISPLAY 

Under UCM6510 web UI->Status->CDR->CDR, click on the icon for “Options”. A new window will be 

popped up displaying more details related to this call. The detailed information includes premier caller, call 

transfer information and etc. 

 

 

 

TURKISH LANGUAGE SUPPORT IN WEB UI 

Turkish can be selected in the language option in the UCM6510 login page, or the language option on the 

web UI upper right after the users log in the UCM6510 web UI. This will switch the web UI language to 

Turkish. 
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FIRMWARE VERSION 1.0.2.7 

PRODUCT NAME 

UCM6510 

DATE 

08/21/2015 

IMPORTANT UPGRADING NOTE 

¶ If needed, UCM6510 1.0.2.7 firmware can be downloaded in below link: 

http://www.grandstream.com/sites/default/files/Resources/Release_UCM6510_1.0.2.7.zip 

CHANGES SINCE FIRMWARE VERSION 1.0.2.5 

ENHANCEMENT 

¶ Added FEC and RTCP support for GVC3200 

¶ Added PRI T310 configuration 

¶ Added Announcement Center feature 

BUG FIX 

¶ Fixed Extension ring simultaneously function does not work on digital trunk 

¶ Fixed FXO echo issue 

 

http://www.grandstream.com/sites/default/files/Resources/Release_UCM6510_1.0.2.7.zip
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FIRMWARE VERSION 1.0.2.5 

PRODUCT NAME 

UCM6510 

DATE 

05/14/2015 

CHANGES SINCE FIRMWARE VERSION 1.0.1.12 

ENHANCEMENT 

¶ Added ability to select voicemail storage (Email+WAV is supported) 

¶ Added option to enable/disable SSH access via LCD or web UI 

¶ Added support to allow remote peer extensions in ring group 

¶ Added ability to strip and prepend digits in inbound routes 

¶ Added ability to search extensions on Extension page 

¶ Added user portal for users to log in with extension number, access user information, extension 

configuration and CDR 

¶ Added support to send Fax via web UI 

¶ Added “Enable LDAP” option to skip the extension from UCM default LDAP phonebook 

¶ Added video RE-INVITE support  

¶ Added DDNS Support 

¶ Added support for Call Barging using feature codes 

¶ Added ability to search the CDR by called number 

¶ Added ability to select the file types for automatic backup 

¶ Added automatic backup support on SD Card or USB storage 

¶ Added support to skip trunk authentication by time condition 

¶ Added option to send P-Asserted-Identity header in SIP Register Trunk 

¶ Added ability to specify trunks in CDR filters 

¶ Added ability to use Pattern in Caller Number to filter CDR 

¶ Added support to send UNREGISTER when VoIP trunk is disabled 

¶ Added LDAP client support 

¶ Added option to specify the chronological order to voice mails 

¶ Added option to configure whether to skip pressing 1/2 to accept or reject calls from Follow Me 

¶ Added option to specify port range in Port Forwarding configuration 

¶ Added ability to go back to IVR menu from Dial By Name by pressing the star key 

¶ Added support to upgrade SIP end device via SD card in Zero Config 

¶ Added ability to filter alert logs 

¶ Added ability to delete alert logs 
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¶ Added NAT option for peer trunk 

¶ Improved Automatic Download CDR result format 

BUG FIX 

¶ Fixed Digital Trunk SS7 signaling mode inbound / outbound call problem 

¶ Asterisk is crashed while using external MCB and CEI 

¶ Fixed cannot make or receive calls with certain E1 lines even when link status shows available 
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FIRMWARE VERSION 1.0.1.12 

PRODUCT NAME 

UCM6510 

DATE 

02/17/2015 

CHANGES SINCE FIRMWARE VERSION 1.0.0.25 

ENHANCEMENT 

¶ Added Active Calls feature to monitor call status and barge in active calls 

¶ Added SVIP FAX Gateway function on FXO, FXS and E1/T1/J1 port 

¶ Added support to disable the trunk for VoIP trunk and analog trunk 

¶ Added RBS support on T1 

¶ Added Frame Relay support on Data Trunk 

¶ Added “Assign CIC to D-channel” option on SS7 settings page 

¶ Added “First CIC” option in SS7 configuration 

¶ Added “D-Chan” selection for PRI and SS7 in editing digital ports 

¶ Added Ring Simultaneously support for extensions 

¶ Added Music On Hold selection per extension 

¶ Added ability to disable the extension per extension 

¶ Added ability to set personal password for making outbound calls per extension 

¶ Added “TEL URI” support for SIP extension and VoIP trunk 

¶ Added “Download Search Result” in CDR 

¶ Added office time and holiday configuration support 

¶ Added time condition support for call forward 

¶ Added support to monitor FXO trunk using SLA 

¶ Added One-Key Dial function 

¶ Added Follow Me support 

¶ Added external number option in IVR key pressing event 

¶ Improved APIs for Zero Config templates and settings 

¶ Added GXP16xx, Surveillance and GS_Wave models in Zero Config support 

¶ Added advanced settings for devices discovered in Zero Config 

¶ Added ability to delete multiple recording files at once 

¶ Added call queue destination if no answer/timeout 

¶ Added call queue Music on Hold customization 

¶ Added restricted AMI access 

Warning: Please do not enable AMI on the UCM6510 if it is placed on a public or untrusted network 
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unless you have taken steps to protect the device from unauthorized access. It is crucial to 

understand that AMI access can allow AMI user to originate calls and the data exchanged via AMI is 

often very sensitive and private for your UCM6510 system. Please be cautious when enabling AMI 

access on the UCM6510 and restrict the permission granted to the AMI user. By using AMI on 

UCM6510 you agree you understand and acknowledge the risks associated with this. 

¶ Added ability to choose the type(s) of files to be cleaned in cleaner 

¶ Added DTMF configuration per SIP trunk 

¶ Added ability to upload and play ring group announcement 

¶ Added ability to upload and play paging call announcement 

¶ Added Alert-info configuration for distinctive ringing on inbound route 

¶ Added ability to prepend digits/trunk name to inbound calls’ caller ID 

¶ Modified Static Routes Interface display when network method is changed 

¶ Renamed the “network backup” settings items to “data sync” 

¶ Added iLBC codec as selected codec on SIP/IAX extension page to support GS Wave 

BUG FIX 

¶ Fixed the voice prompt for Dial By Name is incorrect 

¶ Fixed the UCM doesn’t play ringback tone after blind transfer using feature code 

¶ Fixed CDR isn’t displayed when calling timeout happens 

¶ Fixed if the caller does not off hook phone in 5 busy tones, the call will be dialed again via Failover 

Trunk 

¶ Fixed after call forward unconditional, ringback tone is not played at caller side 

¶ Fixed the static route for WAN interface displays abnormal after changing network method from 

“Route” to “Switch” 

¶ Fixed E1/T1/J1: Inviting a conference participant from web failed because UCM cannot detect DTMF 

¶ Fixed E1/T1/J1: MFC/R2: The caller receives 480 response after callee rejects the call  

¶ Fixed Inbound routes: The call has no ringback tone if the destination is set to DISA and then entering 

an IVR 

¶ Fixed Dial By Name: Call problem when entering Dial by Name after IVR and DISA 

¶ Fixed E1/T1/J1: MFC/R2: Ringback tone can be still heard after the call goes inbound via digital trunk 

to IVR->Ring group and all members reject the call. 

¶ Fixed Static Route: Configuration fails if creating a route->deleting the route->adding the same route 

again 

¶ Fixed Static Route: Deleting a route from web UI doesn’t delete the corresponding route in routetable 

¶ Fixed E1/T1/J1: The DOD number configured for the digital trunk still shows in outbound call after 

deleting the trunk and recreating the trunk 

¶ Fixed Zeroconfig: The actual time period is longer than the configured value in Pick Extension Period 

¶ Fixed FXO: In “Detect” web page under Analog Trunk editing window, if there is another user logging 

in web UI, it will kick out the current login user and the web page shows loading failed 

¶ Fixed Restore: Restoring the configuration in web UI->Maintenance to default value exists exception  

¶ Fixed CDR: When the caller name is longer than 26 characters, it does not display Caller ID 
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¶ Fixed UCM doesn't update Date and Time on LCD 

¶ Fixed Inbound Routes: Sorting arrow is overlapped when clicking on Pattern to sort the inbound rules 

¶ Fixed Firewall: Modifying HTTPS port will cause login failure when enabling Reject Rules in static 

defense 

¶ Fixed Extension: FXS extensions cannot be successfully imported 

¶ Fixed Extension: Exporting an extension with voicemail disabled will cause import failure 

¶ Fixed Zeroconfig: If “Automatically Assign Extension” is disabled, enabling Hot-Desking doesn’t work 

¶ Fixed Backup: When creating backup file, the prompt should be more detailed if the SD/USB storage 

is full 

¶ Fixed Web UI using IE11: Selecting the items of extension list fails 

¶ Fixed Web UI using IE11: Sometimes clicking on the items in web UI->PBX page fails 

¶ Removed "Syn Flood" feature from web UI to improve web UI access efficiency 

 


